Modify

Opened 3 years ago

Closed 3 years ago

#9967 closed defect (duplicate)

IOError: [Errno 2] No such file or directory: ''

Reported by: admin Owned by: hasienda
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

How to Reproduce

While doing a POST operation on /admin/accounts/users, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'af246457eb973d951214ab22',
 'add': u' Add ',
 'cat_id': u'accounts',
 'email': u'',
 'name': u'',
 'panel_id': u'users',
 'password': u'zzzzzz',
 'password_confirm': u'zzzzzz',
 'path_info': None,
 'username': u'll'}

User agent: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0

System Information

Trac 0.12.3
Babel 0.9.6
Genshi 0.6
mod_python 3.3.1
MySQL server: "5.1.54-1ubuntu4", client: "5.1.54", thread-safe: 1
MySQLdb 1.2.2
Pygments 1.4
Python 2.7.1+ (r271:86832, Apr 11 2011, 18:30:20)
[GCC 4.5.2]
pytz 2010b
setuptools 0.6
Subversion 1.6.12 (r955767)
jQuery 1.4.4

Enabled Plugins

TracAccountManager 0.3.2

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.3-py2.7.egg/trac/web/main.py", line 522, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.3-py2.7.egg/trac/web/main.py", line 243, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.3-py2.7.egg/trac/admin/web_ui.py", line 117, in process_request
    path_info)
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.3.2-py2.7.egg/acct_mgr/admin.py", line 137, in render_admin_panel
    return self._do_users(req)
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.3.2-py2.7.egg/acct_mgr/admin.py", line 240, in _do_users
    _create_user(req, env, check_permissions=False)
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.3.2-py2.7.egg/acct_mgr/web_ui.py", line 148, in _create_user
    acctmgr.set_password(username, password)
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.3.2-py2.7.egg/acct_mgr/api.py", line 292, in set_password
    if store.set_password(user, password, old_password):
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.3.2-py2.7.egg/acct_mgr/htfile.py", line 56, in set_password
    self.userline(user, password))
  File "/usr/local/lib/python2.7/dist-packages/TracAccountManager-0.3.2-py2.7.egg/acct_mgr/htfile.py", line 159, in _update_file
    f = open(filename, 'w')
IOError: [Errno 2] No such file or directory: ''

Attachments (0)

Change History (2)

comment:1 Changed 3 years ago by rjollos

  • Component changed from SELECT A HACK to AccountManagerPlugin
  • Owner changed from anonymous to hasienda

comment:2 Changed 3 years ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9623.

Add Comment

Modify Ticket

Action
as closed The owner will remain hasienda.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.