Modify

Opened 2 years ago

Closed 2 years ago

#9991 closed defect (wontfix)

AssertionError: HDF dataset not available.

Reported by: anonymous Owned by: brad
Priority: normal Component: DbAuthPlugin
Severity: normal Keywords: AssertionError HDF dataset login
Cc: Trac Release: 0.11

Description

I would like to have proper "login" control on my trac project. For this reason I have installed dbauth and configured it to work with a mysql database that I set-up through a panel (web admin panel provided by Dream Host).

I believe I have completed most of the steps correctly, the mysql database is fine, it has all the fields in it set. It has an admin user as well. It is accessible. The trac.ini file is configured properly so it links to the database etc. I have used trac-admin to give permissions to the user I have added through mysql.

However I get this error:

Trac detected an internal error:

AssertionError: HDF dataset not available. Check your clearsilver installation
There was an internal error in Trac. It is recommended that you inform your local Trac administrator and give him all the information he needs to reproduce the issue.

To that end, you could a ticket at this site.

The action that triggered the error was:

GET: /login

Not sure what is wrong, this looks like it has nothing to do with the mysql stuff etc. It is more like environment problem?

Any ideas?
Thanks.

Attachments (0)

Change History (3)

comment:1 Changed 2 years ago by anonymous

Any ideas?! Please help me!

comment:2 Changed 2 years ago by rjollos

It looks like the plugin was written to use ClearSilver (the templating engine used by Trac prior to 0.11), and ClearSilver is not installed on your Trac installation. See t:ClearSilver for more details.

comment:3 Changed 2 years ago by rjollos

  • Resolution set to wontfix
  • Status changed from new to closed

See also, this StackOverflow post. You should look at the AccountManagerPlugin, as this plugin has been deprecated.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from brad. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.