wiki:BreadCrumbsNavPlugin

Version 14 (modified by rjollos, 21 months ago) (diff)

Syntax highlighting.

Recently visited pages as navigational bread crumbs

Description

This relatively simple plug-in will inject a list of recently visited pages just above the main navigational bar, as 'bread crumbs' that you can follow home.

See also: BreadcrumbTrailsScript, TracTrailPlugin

Bugs/Feature Requests

Existing bugs and feature requests for BreadCrumbsNavPlugin are here.

If you have any issues, create a new ticket.

ToDo

  • short-term: work on pending feature requests

News

09-Nov-2011
Maintenance release breadcrumbs-0.2 in 0.11 branch with various fixes (open: 4)
08-Nov-2011
Official maintainer change (open: 10)
16-Nov-2010
Starting ticket list cleanup and triage (open: 9)

Installation and Configuration

Prerequisites

Requires Trac >= 0.11 and Genshi >= 0.5 .

Release Status, Downloads and Source

While in general the branch name suggests the corresponding Trac version, 0.11 should work equally well for Trac 0.11 (old stable), 0.12 (current stable) and Trac 0.13dev (development).

Stable Version easy_install https://trac-hacks.org/svn/breadcrumbsnavplugin/0.11 download subversion
Under Development easy_install https://trac-hacks.org/svn/breadcrumbsnavplugin/trunk download subversion

For Subversion checkout use svn co <url> with URL depending on your Trac version and target release (see links above).

Other alternatives:

Installation

The easiest way to install the BreadCrumbsNavPlugin is to simply point easy_install at the t-h.o SVN repository, a la:

 easy_install http://trac-hacks.org/svn/breadcrumbsnavplugin/0.11

Alternatively, you may download the source, go into the directory containing setup.py and run:

 python setup.py install

or prepare a packaged version and move that into the plugin directory inside your Trac environment:

 python setup.py bdist_egg
 cp ./dist/BreadCrumbsNav-<version> <path-to-trac-env>/plugins/

Hint: Using tracd standalone server or another webserver you will most probably need to restart it to detect the plugin.

Depending on your configuration you may still need to enable the plugin explicitly. You can do so in the Administration panel of Trac, or in trac.ini by adding:

[components]
breadcrumbsnav.* = enabled

In Trac applications, where you disabled breadcrumbs-0.1 or required explicit activation, a different line starting with breadcrumbsnavplugin. is already present that is now obsolete and could be deleted safely.

Configuration

There are four options you may set in trac.ini:

ignore_pattern
A regular expression pattern that can be applied to the name of the resource; if it matches the resource will not be added to the user's breadcrumbs. Defaults to nothing.
label
A custom label to replace the implicite "Breadcrumbs:" default value. Beware that this will interfere with i18n, maybe even depreciated by it.
max_crumbs
The maximum total of crumbs that should be kept per-user. Defaults to 6.
paths
A comma-separated list of regular expressions, one of which should match the beginning of the url to include the resource in the path. Defaults to /wiki*,/ticket*,/milestone* Note that these really are interpreted as regular expressions, even though the default values look more like shell globs. It seems these default values also match /wik/foo or /tickebar, which might not be the authors intention.

The config entry would look something like the following:

[breadcrumbs]
ignore_pattern =
label =
max_crumbs = 6
paths = /wiki/,/ticket/,/milestone/

Recent Changes

[10902] by hasienda on 2011-11-11 19:39:33
BreadCrumbsNavPlugin: Hide currently viewed page/resource from list, refs #9529.
[10901] by hasienda on 2011-11-11 19:35:16
BreadCrumbsNavPlugin: Fix crumbs list handling, refs #3965.

Code introduced in [10893] was not handling an empty list gracefully.
Futhermore, when hiding of current resource results in an empty list, the
list label should be suppressed as well.

[10896] by hasienda on 2011-11-09 20:57:40
BreadCrumbsNavPlugin: Tag long overdue maintenance release 0.2, closes #2463, #3965, #4037, #4411, #7036 and #7231.

Fix erroneously introduced version mismatch between changelog and setup.py.

Author/Contributors

Author: ixokai
Maintainer: hasienda
Contributors: