wiki:OverrideEditPlugin

Version 5 (modified by bobbysmith007, 4 years ago) (diff)

Added trac 12 version stuff

Allow changes to be saved even when ticket has been modified

Description

A plugin that replaces the default trac ticket validation with a version that, after showing you the warning (Warning: Sorry, can not save your changes. This ticket has been modified by someone else since you started), allows you to save anyway.

The vast majority of times this error is signaled, both changes are additive and can be safely applied so lets not force people to jump through hoops unnecessarily.

This is what happens when someone made a comment while you were commenting:
This is what happens when someone has edited the description. If you save you will lose their change (so go edit it back in)

Bugs/Feature Requests

Existing bugs and feature requests for OverrideEditPlugin are here.

If you have any issues, create a new ticket.

Download

Download the zipped source from:

Source

You can check out OverrideEditPlugin from:

or browse the source with Trac.

Example

Mostly just allow you to bypass the warning about the ticket changing since you last looked at it.

Recent Changes

[11104] by bobbysmith007 on 2012-01-03 21:31:45
dont do our special stuff if there is not a ticket id. we must be on a saved ticket with a ticket id in the request for this to behave fix #9660
[8290] by bobbysmith007 on 2010-07-22 17:58:31
fixed bug in parsing some iso8601 dates that cause the time to be off by a millisecond or so, and thus fail ticket validation. fix #7402
[8283] by bobbysmith007 on 2010-07-19 22:53:56
fixed egregious bug that disalloowed newtickets

Author/Contributors

Author: bobbysmith007
Contributors:

Attachments (2)

Download all attachments as: .zip