Changes between Version 34 and Version 35 of ProgressMeterMacro


Ignore:
Timestamp:
Aug 31, 2010 3:40:09 AM (4 years ago)
Author:
qwp0
Comment:

A note about the status arg handling, plus I'm not sure the plugin will work with Trac 0.11 anymore.

Legend:

Unmodified
Added
Removed
Modified
  • ProgressMeterMacro

    v34 v35  
    55This macro plugin was created because of [http://code.google.com/p/google-highly-open-participation-psf/issues/detail?id=256 this task] for GHOP/Python Software Foundation. 
    66 
    7 It contains a macro to display a progress meter similar to the meters visible in the Roadmap.  In a wiki page it can be used, for example, for building a complete report of the progress on tickets owned by a particular person. The !ProgressMeter macro works with the same comma-separated list of keyed parameters (named fields of a ticket) as the [http://trac.edgewall.org/wiki/TicketQuery TicketQuery macro], except the argument [#status-arg status], which is ignored. 
     7It contains a macro to display a progress meter similar to the meters visible in the Roadmap.  In a wiki page it can be used, for example, for building a complete report of the progress on tickets owned by a particular person. The !ProgressMeter macro works with the same comma-separated list of keyed parameters (named fields of a ticket) as the [http://trac.edgewall.org/wiki/TicketQuery TicketQuery macro], except the argument {{{[#status-arg status]}}} and {{{format}}}. 
    88 
    99For more complex progress statistics and metrics see TracMetrixPlugin. 
     
    3131=== The {{{status}}} argument === #status-arg 
    3232 
    33 The `status` argument is ignored since r5224. If you want to define which ticket states are considered closed have a look at [trac:wiki:TracIni#milestone-groups-section the appropriate section of trac.ini] instead. 
     33The `status` argument ~~is ignored since r5224~~ triggers an error since r8558. If you want to define which ticket states are considered closed have a look at [trac:wiki:TracIni#milestone-groups-section the appropriate section of trac.ini] instead. 
    3434 
    3535== Download == 
     
    4343== Installation == 
    4444 
    45 See [trac:wiki:TracPlugins#InstallingaTracPlugin] for the installation instructions. Please note Trac 0.11.5 is a minimum requirement in order for the plugin to work. 
     45See [trac:wiki:TracPlugins#InstallingaTracPlugin] for the installation instructions. Please note Trac 0.12 is a minimum requirement in order for the plugin to work. 
    4646 
    4747== Bugs/Feature Requests ==