Changes between Version 32 and Version 33 of SiteUpgradeProposal


Ignore:
Timestamp:
Jul 30, 2012, 1:36:47 AM (2 years ago)
Author:
hasienda
Comment:

note available Python versions in Debian Sqeeze

Legend:

Unmodified
Added
Removed
Modified
  • SiteUpgradeProposal

    v32 v33  
    1717 * Upgrade server to Debian Squeeze.
    1818 * Python: 2.5 -> 2.7 - optional, Trac 1.0 will not require more than 2.5.
     19>  Debian Squeeze comes with Python2.5, 2.6 (default) and 3.0, so 2.7 is not an immediate option. We should rather decide on keeping 2.5 or going with new system default after the server-upgrade. I'd prefer to keep 2.5 as fallback, if we run into problems after the upgrade. But I've not seen any code that had issues with 2.6 after running with 2.5, so this seems very low-risk to me. Most probably we'll just have to re-create eggs for the new Python version.
    1920 * TODO: define some enhancements for this milestone (e.g. BookmarkPlugin, TracPastePlugin, IrcLogsPlugin, etc ...).
    2021