Changes between Version 11 and Version 12 of TracBlogPlugin


Ignore:
Timestamp:
Apr 17, 2006, 6:39:54 PM (9 years ago)
Author:
pacopablo
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • TracBlogPlugin

    v11 v12  
    2828
    2929== Installation ==
    30 TracBlogPlugin has been tested with the current trunk, though should work on 0.9.x
     30TracBlogPlugin will work with the current trunk and 0.9.x
     31
    3132=== Requirements ===
    32  * TagsPlugin >= 0.3
     33 * TagsPlugin >= 0.3 and < 0.5
    3334 * [t:WebAdmin WebAdmin]
     35
     36If using 0.9.x it may be necessary to install the TagsPlugin and the [t:WebAdmin WebAdmin] plugin globally instead of the project's plugin directory.  This is due to the need for those plugins to load before the TracBlogPlugin loads.  Unfortunately, 0.9.x does not support plugin dependencies, so the only way to get it to work properly is installing the above plugins globally via:
     37{{{
     38# python setup.py install
     39}}}
     40An indication that this may be the case is if a message similar to the following is displayed
     41{{{
     42...
     43resolve
     44    raise DistributionNotFound(req)  # XXX put more info here
     45DistributionNotFound: TracWebAdmin
     46}}}
    3447
    3548Install in the same manner as any other Trac plugin:
     
    3952}}}
    4053
    41 You will also probably need to enable the plugin in your environments trac.ini:
     54If the TracBlogPlugin is installed system wide, then you will need to enable the plugin in your trac.ini:
    4255{{{
    4356[components]
    44 tracblog.* = enabled
     57tBlog.* = enabled
    4558}}}
    4659