wiki:TracDownloaderPlugin

Version 13 (modified by anonymous, 7 years ago) (diff)

--

Trac Downloader plug-in

Description

Project release downloader plugin for Trac system with optional questionnaire before download of file, Captcha antirobot check, stats module and easy to use administration in Trac WebAdmin plug-in.

Bugs/Feature Requests

Existing bugs and feature requests for TracDownloaderPlugin are here.

If you have any issues, create a new ticket.

Download

If you don't like Subversion you can download egg or full source here:
TracDownloader-0.1-trac-0.9.egg
TracDownloader-0.1-trac-0.9.zip
TracDownloader-0.1-trac-0.10.egg
TracDownloader-0.1-trac-0.10.zip

Here are some screenshots too.

Download the zipped source for Trac 0.9 or Trac 0.10.

Source

You can check out TracDownloaderPlugin from here using Subversion, or browse the source with Trac.

Example

The easiest way to start using Downloader plug-in is to get downloaded python egg into plugin directory of project environment (egg is most probably python version independent, just rename it, but who knows, there's still source package...), after that you must turn both modules of Downloader on in WebAdmin/plugins (Downloader is dependent on WebAdmin plug-in). And finally there is need to get some permissions of Downloader to some users... In this case if you like to use PyCaptcha, you must take care of installing it by yourself, PyCaptcha is dependent on PIL so you must download it too.

Second and maybe better way is to download and unpack somewhere source zip package and then just run "setup.py install". Setup should take care of all dependences (PyCaptcha and PIL) and prepaire plugin to be turned on in WebAdmin/plugins. Then you must assign some permissions of downloader to someone and you can start trying Downloader plug-in...

Recent Changes

[12139] by rjollos on 2012-10-10 03:54:13
Fixed incorrect source code encoding (http://www.python.org/dev/peps/pep-0263/).
[11235] by rjollos on 2012-02-02 23:12:33
Refs #4299: Fixed setup.py syntax error for the 0.10 branch. The 0.10 branch won't be supported. This fix is untested.
[11234] by rjollos on 2012-02-02 22:14:57
Fixes #5540: Fixed encoding error in defining the navigation item for the INavigationContributor interface.

Author/Contributors

Author: Škoda?
Contributors:

Attachments (8)

Download all attachments as: .zip