wiki:WikiIncludePlugin

Version 11 (modified by rjollos, 4 years ago) (diff)

Download includes 0.9 and 0.11

Wiki Include Plugin

Description

When the WikiInclude macro is used, there is an error being displayed occasionally.

Please see MacroMigrationTutorial for the reasons.

This plug-in offers the same function, without issuing an error.

Bugs/Feature Requests

Existing bugs and feature requests for WikiIncludePlugin are here.

If you have any issues, create a new ticket.

Download

WikiIncludePlugin

Source

You can check out the source for WikiIncludePlugin from Subversion at http://trac-hacks.org/svn/wikiincludeplugin.

Installation

  • Build the egg file following the plugin packaging instructions
  • Copy the dist/WikiIncludePlugin-0.y.z-py2.3.egg file in your plugins project directory.
  • Requires setup in trac.ini.
    [components]
    wikiinclude.* = enabled
    
  • If you are using the WikiInclude macro, you need to remove wiki-macros/WikiInclude.py

Example

[[WikiInclude(Foo)]]
[[WikiInclude(Foo|Argument1|Argument2..|ArgumentN)]]

Version 0.2 (see attachment) with possibility to include specific page version:

[[WikiInclude(Specification?version=7)]]

Author/Contributors

Author: yu-ji
Contributors: bubacoo

TagIt(plugin,0.9,yu-ji)?