Modify

Opened 7 years ago

Closed 4 years ago

Last modified 4 years ago

#12588 closed enhancement (duplicate)

TicketValidator enhancement/feature addition for TicketType

Reported by: lacriox@… Owned by:
Priority: normal Component: TicketValidatorPlugin
Severity: normal Keywords: Enhancement, Feature Add
Cc: Ryan J Ollos Trac Release:

Description

rjollos, David Healey again, I can't find where I found this original zipped version of Ticketvalidator, but with a few changes, I've come up with the following attachement and I was wondering if this might be something usable in the future or currently. I'm having a bit of trouble getting the functionality working correctly, it's actually very strange, sometimes it does and sometimes it just doesn't, I think there is something wrong with my build out here on my test machine in the office. At any rate, I'm hoping you find this useful. Let me know what you think.

David.

Attachments (1)

ticketvalidator.zip (19.2 KB) - added by lacriox@… 7 years ago.
Updated ticketvalidator.

Download all attachments as: .zip

Change History (11)

Changed 7 years ago by lacriox@…

Attachment: ticketvalidator.zip added

Updated ticketvalidator.

comment:1 Changed 7 years ago by lacriox@…

Attached, I've copied the source in which I was working on. You will note a number of interface as well as functional changes within. (1) Addition of option ticket type for required fields (2) Repackaged and corrected setup.py configuration to package the whole plugin as one rather than two separate entities (3) Different help structure for more understandable usage (4) Functionality to update/change trac.ini [ticketvalidator] section upon submital. (5) Restructured all sources correctly.

NOTE: the functionality actually does work without the option ticket-type, however, I have had hit/miss luck with the optional ticket-type field added, I believe my testing environment is broken and haven't been able to find the time to straighten it out. All other functionality proven to work/tested. dbh

comment:2 Changed 7 years ago by lacriox@…

I found where I got the original code I modified :

#7218 closed enhancement (duplicate)

Looping in Reinhard, and superafroman for more intel.

comment:3 Changed 7 years ago by anonymous

superafroman:

You initial code was good, I made some modifications and restructured the line, corrected the setup.py to create a single package plugin containing all enabled/disabled features within the trac/admin/plugin panel. and updated the version information based on the changes I've made. rjollos : Please refer to my notes above.

All : This in my opinion, is the correct implementation of specifically requiring user input throughout the life cycle of a given task or change. Any and All input / ideas / Comments and Yes even Criticisms welcome, I am a novice python programmer.

Thank you.

comment:4 Changed 7 years ago by Ryan J Ollos

Patch files are highly preferred. See TracDev/SubmittingPatches. I'll see about reviewing what you submitted though.

comment:5 in reply to:  4 Changed 7 years ago by anonymous

Replying to rjollos:

Patch files are highly preferred. See TracDev/SubmittingPatches. I'll see about reviewing what you submitted though.

I'll look at the TracDev/SubmittingPatches you've refered me to, My apologies. Thank you for reviewing my changes, I do appreciate it.

I'm rather slammed in the office, but since this is actually one of the things I am slammed with I should be able to resubmit the patch files within the next week or so providing of course I can figure that part out. Hope you've all had a Great Holiday Season thus far.

Thanks Again. David B Healey. lacriox@…

comment:6 Changed 7 years ago by Ryan J Ollos

Thanks, I'm pretty busy with other tasks on trac-hacks.org so I'll wait until you submit the patches to review.

comment:7 in reply to:  6 Changed 7 years ago by lacriox@…

Replying to rjollos:

Thanks, I'm pretty busy with other tasks on trac-hacks.org so I'll wait until you submit the patches to review.

Sounds like a plan. I'll get it to you as soon as I can.. Question, and I'm sorry for being a pain in the ass, but ... Do I just zip up the patch files, and submit them here via attachment or ??

comment:8 Changed 7 years ago by Ryan J Ollos

You can just upload the patch file directly. Running the patch operation against a modified Subversion working copy will yield a single patch file.

Version 0, edited 7 years ago by Ryan J Ollos (next)

comment:9 in reply to:  8 Changed 7 years ago by lacriox@…

Replying to rjollos:

You can just upload the patch file directly. Running the svn diff operation against a modified Subversion working copy will yield a single patch file.

Okay sounds good, I'll try and get that as soon as possible. Thank you for the info and speedy response I appreciate it.

comment:12 Changed 4 years ago by Ryan J Ollos

Resolution: duplicate
Status: newclosed

Duplicate of #8897.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The ticket will remain with no owner.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.