Version 11 (modified by rjollos, 4 years ago) (diff)

I'll maintain this.

Automatically creates links for all known Wiki pages


Automatically create links for all known Wiki pages, even those that are not in CamelCase.

For example, with this plugin enabled, the bare word plugin would be linked thus plugin. Autolinking a word can be disabled by prefixing the word with !, as is done for disabling autolinking of CamelCase wiki pages.


The AutoWikifyPlugin has three configurable options in TracIni, both in the autowikify section:

minimum_length=<int>Override the default minimum of 3 character long page names recognised.
explicitly_wikify=<name>[, <name> ...]Specify a list of names to explicitly wikify.
exclude=<name>[, <name> ...]A list of names to exclude from autowikification.

If you are installing this plugin 'globally', you will need to add the following entry to the components section of your trac-ini file:

tracautowikify.* = enabled

If you want to use the configuration options mentioned above, add the following section to that same file (NOTE: Use 'autowikify' for this section, not 'tracautowikify'):


Bugs/Feature Requests

Existing bugs and feature requests for AutoWikifyPlugin are here.

If you have any issues, create a new ticket.

regex based wildcards in explicitly_wikify

If like me ( SvenDowideit ) you want to link to an external wiki (TWiki) and need a large set of non-CamelCase words (in this case our bug tracking system (of the style of Bugs.Item1234) the you can modify to remove the escaping of regex strings -


        pattern = r'\b(?P<autowiki>' + '|'.join([re.escape(page) for page in pages]) + r')\b'


        pattern = r'\b(?P<autowiki>' + '|'.join([page for page in pages]) + r')\b'


Download the zipped source from [download:autowikifyplugin here].


You can check out AutoWikifyPlugin from here using Subversion, or browse the source with Trac.

Recent Changes

15264 by rjollos on 2016-02-11 05:22:34
Remove unnecessary svn:mime-type on py files

svn:mime-type was set to "plain" for many files.

14821 by rjollos on 2015-07-20 06:40:00
0.2: Require Trac >= 0.11.
14746 by rjollos on 2015-06-25 21:44:17
0.2: Release version 0.2.


Author: athomas
Maintainer: rjollos