Changes between Initial Version and Version 4 of Ticket #8803


Ignore:
Timestamp:
May 17, 2011, 2:38:26 AM (4 years ago)
Author:
rjollos
Comment:

I sympathize with RHEL users that it still runs Python 2.4, but note that Trac 0.13 will only support Python 2.5 and later, so we are moving to a stage that will force RHEL users to upgrade or install Python 2.5 themselves.

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #8803

    • Property Owner changed from anonymous to Blackhex
    • Property Status changed from new to assigned
    • Property Component changed from SELECT A HACK to DiscussionPlugin
  • Ticket #8803 – Description

    initial v4  
    1 I would like to enable Discussion plugin 0.11 (from svn) for Trac 12.2 on my enterprise RHEL 5.4 system running python2.4. However, it appears that several lines of python 2.5 code (if oneliners for example) break python 2.4 compatibility. I noticed that there was a python2.4 patch few revisions back, so I tried to check out SVN r9590, apply the patch, and install the plugin. This did not work and Trac kept issuing a WARNING in the log: Component <tracdiscussion.init.DiscussionInit object at 0x2ade4de3d7d0> requires environment upgrade. Running "trac-admin ...  upgrade" did not solve the issue, even though permissions were set correctly. I am currently stuck.
     1I would like to enable Discussion plugin 0.11 (from svn) for Trac 12.2 on my enterprise RHEL 5.4 system running python2.4. However, it appears that several lines of python 2.5 code (if oneliners for example) break python 2.4 compatibility. I noticed that there was a python2.4 patch few revisions back, so I tried to check out SVN r9590, apply the patch, and install the plugin. This did not work and Trac kept issuing a WARNING in the log:
     2
     3{{{
     4Component <tracdiscussion.init.DiscussionInit object at 0x2ade4de3d7d0> requires environment upgrade. Running "trac-admin ...  upgrade" did not solve the issue, even though permissions were set correctly. I am currently stuck.
     5}}}
     6
    27Does anyone maintain a more current python2.4 patch?
     8
    39It is a shame that this valuable plugin does not maintain compatibility with widely used (especially on older and enterprise systems) python2.4 for reason no other than to save a few lines of code.