Modify

Opened 23 months ago

Closed 22 months ago

Last modified 22 months ago

#10308 closed defect (fixed)

Issue with installing trachoursplugin

Reported by: binoy.edathiparambil@… Owned by: rjollos
Priority: normal Component: TracHoursPlugin
Severity: normal Keywords: installation setup.py
Cc: Trac Release: 0.11

Description (last modified by rjollos)

My environment is windows+apache+trac 0.11+mySql.

I was trying to install trachoursplugin and I think I followed the instructions on enabling the plugin. I made sure that I installed and enabled in the trac.ini:

componentdependencies.* = enabled
ticketsidebarprovider.* = enabled
tracsqlhelper.* = enabled

After that I tried to install the trachoursplugin, I following error - This is towards the end of the install process.

Installed c:\python25\lib\site-packages\trachoursplugin-0.5.2-py2.5.egg
Processing dependencies for TracHoursPlugin==0.5.2
Searching for Python>=2.5
Reading http://pypi.python.org/simple/Python/
Reading http..../2.5
Reading http:.../2.4
Reading http.../2.3
Reading http.../2.4.1
Reading http...thon.org
Reading http..../download/
Best match: Python 3.2.3
Downloading http://www.python.org/ftp/python/3.2.3/Python-3.2.3.tgz
Processing Python-3.2.3.tgz
Running Python-3.2.3\setup.py -q bdist_egg --dist-dir c:\docume~1\c00vxw\locals~
1\temp\easy_install-gp-z-f\Python-3.2.3\egg-dist-tmp-umktic
setup.py:250: Warning: 'with' will become a reserved keyword in Python 2.6
error: c:\docume~1\c00vxw\locals~1\temp\easy_install-gp-z-f\Python-3.2.3\setup.p
y: The process cannot access the file because it is being used by another process

I am not sure why the install is looking for python 2.5 when 2.5 is already installed on the machine. Also why does it finally land on 3.2.3?

The end result is I don't see any new table changes in the database and I also don't see the sidebar changes. When I try to run trac-admin <env> upgrade, I get the message nothing to upgrade! Can you please help me with this issue?

Attachments (0)

Change History (14)

comment:1 Changed 23 months ago by rjollos

  • Description modified (diff)
  • Status changed from new to assigned

comment:2 Changed 23 months ago by rjollos

Did you see my response to your initial post in ticket/8690? Please try again with the latest version of the source, r11948 or later.

comment:3 Changed 23 months ago by rjollos

Oh, I see that wasn't you in ticket/8690. Well, I think it will work with the latest version of the source. Please let me know.

comment:4 follow-up: Changed 23 months ago by binoy.edathiparambil@…

  • Trac Release changed from 0.11 to 1.0

Thank you for your response. I was able to move past the previous after copied over the latest source. Now I have a new issue. I executed trac-admin project-path upgrade and I get the following error:

C:\Python25\Scripts>trac-admin.exe C:\tracdata\web upgrade --no-backup
The upgrade failed. Please fix the issue and try again.

TypeError: __init__() got an unexpected keyword argument 'unique'

I can see the new tables in the database and updates are all done! Also when I go to trac via the browser I get:

Trac Error
TracError: The Trac Environment needs to be upgraded.
Run "trac-admin c:\tracdata\web upgrade"

I tried search for this issue and I did check if the permissions to the trac.ini has correct permissions and it does!

Can you please help me?

The error goes away if I disable the trachours plugin!

comment:5 Changed 23 months ago by rjollos

I'm not sure what the problem might be. Have you tried without the --no-backup switch?

comment:6 Changed 23 months ago by rjollos

I've done some more testing and can't reproduce. I'd suggest posting to the t:MailingList and maybe someone else will have a better idea of the problem.

comment:7 Changed 23 months ago by rjollos

I have a lead, see #7276. I will try to get a patch applied tomorrow. Thanks for your patience.

comment:8 follow-up: Changed 23 months ago by rjollos

The unique attribute of the title column was removed in [8060]. The only explanation for the behavior you are seeing is that you have installed from trachoursplugin/branches/0.11. However, if you are running Trac 1.0 as reported in this ticket, then that is clearly not the branch of TracHoursPlugin that you want to be running. Please install from the trachoursplugin/trunk and report back.

I plan to revisit [8060] and make sure the "blind removal" of the unique attribute didn't cause any other issues.

I'm also interested in your overall experience with TracHoursPlugin in Trac 1.0. Please don't hesitate to report any issues you find, and I will try to fix them promptly. If you don't have any issues, I'd even appreciate a report of successful install and usage under Trac 1.0, as it will help me gauge the stability of the code under that release.

comment:9 Changed 23 months ago by rjollos

(In [11993]) Refs #10308: Deleted the 0.12 branch. All changes in the 0.12 branch exist on the trunk and the trunk is intended to be compatible with Trac 0.12, so there is no need for a dedicated branch. Further, this will reduce ambiguity since the 0.11 and 0.12 branches both had the version number 0.5.2. Currently, the trunk has version 0.6.0dev.

comment:10 in reply to: ↑ 4 Changed 23 months ago by rjollos

  • Keywords installation setup.py added
  • Trac Release changed from 1.0 to 0.11

Replying to binoy.edathiparambil@coleparmer.com:

Thank you for your response. I was able to move past the previous after copied over the latest source.

I'm confused about what has transpired here. You say that you've copied over the latest source and it fixed the problem with the Python version being specified in setup.py, but the only reasonable explanation I see is that you have copied over the 0.11 branch of the TracHoursPlugin, and prior to [11993] the 0.11 branch had the same issue with the Python version being specified in setup.py, which is known to cause problems (see #9800 for some explanation).

In comment:description, you state that your Trac version is 0.11, but you set the Trac Release field to 1.0 in comment:4. When you say that you copied over the latest source, do you mean that you copied over the latest source for Trac or that you copied over the latest source for TracHoursPlugin? Were you running Trac 0.11 when you opened the ticket and running Trac 1.0 now?

Could you provide some more detailed explanation about the steps you took so that I can better understand how we ended up here? Your explanation might point to some other issues that I could improve upon to help with the installation experience of TracHoursPlugin. Please let me know which version of Trac you are running, and if it is not clear already, I will help make sure you have the appropriate source for the TracHoursPlugin.

comment:11 in reply to: ↑ 8 Changed 23 months ago by rjollos

Replying to rjollos:

I plan to revisit [8060] and make sure the "blind removal" of the unique attribute didn't cause any other issues.

It looks like this is okay since the unique parameter was never utilized inside the Column constructor, therefore having no effect. See [t 9406/trunk/trac/db/schema.py] and #7276.

comment:12 follow-up: Changed 22 months ago by rjollos

  • Resolution set to fixed
  • Status changed from assigned to closed

Please reopen if your issue is not resolved and my previous comments haven't provided enough clarity.

comment:13 in reply to: ↑ 12 ; follow-up: Changed 22 months ago by binoy.edathiparambil@…

Replying to rjollos:

Please reopen if your issue is not resolved and my previous comments haven't provided enough clarity.

Hey!

Thank you for following up with me regarding this ticket. So here is a quick summary of what happened and what I ended up doing. We used to have 0.11 version of track and then I decided to use trachoursplugin. So I followed the documentation and installed all the dependency plugins. Finally I installed the trachoursplugin and then I carried out the step of upgrade which for some reason upgraded the entire trac! I was suddenly put on the newest version 1.0! I did not expect this auto upgrade and fortunately I had to do a very little tweaks to us fully working on the newest version.

Even on the new version I was getting the error with installing the plugin finally I made a few tweaks to the source like removing the unique and was able to get the plugin working.

I then installed worklog plugin which was using the old way of counting the number of comments so tweaked that code to make it stop using the count for comments.

So after making all these tweaks I now have the current version of trac - 1.0 and I have trachoursplugin and worklog plugin all working nicely!

Let me know if you need more information about this issue and now I went about fixing it.

Regards,
Binoy

comment:14 in reply to: ↑ 13 Changed 22 months ago by rjollos

Replying to binoy.edathiparambil@coleparmer.com:

Let me know if you need more information about this issue and now I went about fixing it.

Hi, Thanks for the reply. Would you mind sending along patches for both plugins? I won't assume anything, and say that in case you aren't familiar with patches, you'd make the patch from the root of the working copy like this: svn diff > trachours.patch.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.