Modify

Opened 2 years ago

Closed 23 months ago

#10352 closed defect (fixed)

User redirected to empty page after attaching screenshot (missing trailing slash in URL)

Reported by: prav Owned by: seccanj
Priority: normal Component: ScreenshotPastePlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

Hi,

I have this plugin installed along with my trac and found this bug recently which can be quite annoying and confusing to the users.

This happens only when the user is creating a new ticket and attaching a screenshot using the plugin. The ticket gets created, the user is able to paste the screenshot, but when he hits "Send the screenshot" he is redirected to an empty page like the one attached.

The problem is a missing trailing slash "/" in the URL. The page is redirected to "/attachment/ticket/183" for example while it should have been redirected to "/attachment/ticket/183/".
It would be great if someone would look into this.

Thanks.

Attachments (1)

06.png (20.8 KB) - added by prav 2 years ago.
redirected to empty ticket page

Download all attachments as: .zip

Change History (3)

Changed 2 years ago by prav

redirected to empty ticket page

comment:1 Changed 2 years ago by rjollos

I don't use this plugin (yet), but I've experienced the problem with needing a forward slash. There is a ticket open for the issue in the Trac core (t:#10280), but the specified workaround is needed for now.

comment:2 Changed 23 months ago by seccanj

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with 0.1.2.

Get it here!

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.