Modify

#10569 closed defect (fixed)

Can't delete unused test case templates

Reported by: anonymous Owned by: seccanj
Priority: normal Component: TestManagerForTracPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

Trying to delete an unassigned test case template in the test manager template admin page results in a warning, that the template can't be deleted as it is in use by a test catalog. The warning appears also for templates that are not assigned to any catalog at all.

Attachments (1)

TemplateDelete.jpg (208.8 KB) - added by marcel.tschanen@… 21 months ago.
Template delete warning

Download all attachments as: .zip

Change History (5)

Changed 21 months ago by marcel.tschanen@…

Template delete warning

comment:1 follow-up: Changed 21 months ago by seccanj

Hi Marcel,
I tried to reproduce this problem but couldn't.

Checking the code, saving a template can give this message also if some error occurs while checking if it is in use gives an error.
In this case, anyway, the error is printed in the log file.

Could you then please check the log file for a message like this:
"Error checking if template with id 'xxx' is in use"

and paste the error reason here?

Ciao,
Roberto

comment:2 in reply to: ↑ 1 ; follow-up: Changed 21 months ago by wthie

Replying to seccanj:

Hi Marcel,
I tried to reproduce this problem but couldn't.

Checking the code, saving a template can give this message also if some error occurs while checking if it is in use gives an error.
In this case, anyway, the error is printed in the log file.

Could you then please check the log file for a message like this:
"Error checking if template with id 'xxx' is in use"

and paste the error reason here?

Ciao,
Roberto

Hi Roberto

speculatively, the id of this template is 0, which seems to be a default value picked up by the zombie templates #10567.

Trying to delete a test case template with such an id == 0 does not lead to an error in the logfile, the template is simply signaled as in use.

Werner

comment:3 in reply to: ↑ 2 Changed 21 months ago by marcel.tschanen@…

Hi Roberto
I've made some more tests. When I create new templates now I can easily edit them, assign them to test catalogs, remove the assignment and then delete them.

All three test case templates I created a week ago can't be deleted. They seem to be assigned to some test catalogs that don't exist anymore. When creating a new sub catalog, one of the test case templates was automatically assigned to the new catalog. So maybe the template id is stored in some default table.
Hope this additional information helps.
Best regards, Marcel

comment:4 Changed 15 months ago by seccanj

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in 1.6.1.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from seccanj. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.