Modify

Opened 22 months ago

Closed 22 months ago

Last modified 22 months ago

#10652 closed defect (duplicate)

ProgrammingError: (1146, "Table 'trac_contacts.tags' doesn't exist")

Reported by: akliewer99 Owned by: hasienda
Priority: normal Component: TagsPlugin
Severity: major Keywords: MySQL 5.5.28 SQL syntax compatibility
Cc: Trac Release: 1.0

Description

How to Reproduce

I completed the installation of this new plugin to my project. While performing the upgrade I received the below error.

trac-admin contacts upgrade
Error: AttributeError: ''

I checked my phpMyAdmin and determined that the SQL statement did NOT execute.

  "Table 'trac_contacts.tags' doesn't exist. "

Pretty please email me the SQL statement so I can get this plugin installed.

I have a fresh Trac install (only a few tickets) with some other plugins and I am using the MYSQL 5.5.28 with a freshly compiled from source Python 2.7 MySQLdb connector to a mysql database. See attached screen print of database from my phpmyadmin page.

I would love to help out with any beta testing or other things I can do. My version of Eclipse isn't setup for python but it bet wouldn't take much.

Just let me know what I can do to help out!

Thanks,
Arlene Kliewer

akliewer 99 @gmail.com
Sacramento, CA

User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:16.0) Gecko/20100101 Firefox/16.0

System Information

Trac 1.0
Genshi 0.6 (without speedups)
mod_wsgi 3.3 (WSGIProcessGroup WSGIApplicationGroup amktrac|/contacts)
MySQL server: "5.5.28-log", client: "5.5.28", thread-safe: 1
MySQLdb 1.2.4c1
Python 2.7.1 (r271:86832, Jul 31 2011, 19:30:53)
[GCC 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00)]
setuptools 0.6
jQuery 1.7.2

Enabled Plugins

IniAdmin 0.3-r12307
Tracchildtickets 2.5.2
Tracchildtickettreemacro 1.0.1
TracMasterTickets 3.0.3
TracNav 4.1
TracTags 0.6
TracWysiwyg 0.12.0.4-r11158
Wikinfo 0.2dev

Python Traceback

Traceback (most recent call last):
  File "/Library/Python/2.7/site-packages/Trac-1.0-py2.7.egg/trac/web/main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "/Library/Python/2.7/site-packages/Trac-1.0-py2.7.egg/trac/web/main.py", line 233, in dispatch
    content_type)
  File "/Library/Python/2.7/site-packages/Trac-1.0-py2.7.egg/trac/web/chrome.py", line 968, in render_template
    stream |= self._filter_stream(req, method, filename, stream, data)
  File "build/bdist.macosx-10.7-intel/egg/genshi/core.py", line 132, in __or__
    return Stream(_ensure(function(self)), serializer=self.serializer)
  File "/Library/Python/2.7/site-packages/Trac-1.0-py2.7.egg/trac/web/chrome.py", line 1147, in inner
    data)
  File "build/bdist.macosx-10.7-intel/egg/tractags/wiki.py", line 42, in filter_stream
    return self._wiki_view(req, stream)
  File "build/bdist.macosx-10.7-intel/egg/tractags/wiki.py", line 87, in _wiki_view
    tags = self._page_tags(req)
  File "build/bdist.macosx-10.7-intel/egg/tractags/wiki.py", line 83, in _page_tags
    tags = sorted(tag_system.get_tags(req, resource))
  File "build/bdist.macosx-10.7-intel/egg/tractags/api.py", line 203, in get_tags
    .get_resource_tags(req, resource))
  File "build/bdist.macosx-10.7-intel/egg/tractags/api.py", line 120, in get_resource_tags
    (self.realm, resource.id))
  File "/Library/Python/2.7/site-packages/Trac-1.0-py2.7.egg/trac/db/util.py", line 65, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/Library/Python/2.7/site-packages/MySQL_python-1.2.4c1-py2.7-macosx-10.7-intel.egg/MySQLdb/cursors.py", line 201, in execute
    self.errorhandler(self, exc, value)
  File "/Library/Python/2.7/site-packages/MySQL_python-1.2.4c1-py2.7-macosx-10.7-intel.egg/MySQLdb/connections.py", line 36, in defaulterrorhandler
    raise errorclass, errorvalue
ProgrammingError: (1146, "Table 'trac_contacts.tags' doesn't exist")

Attachments (1)

TracTags mysql db no tags table.png (550.9 KB) - added by akliewer99 22 months ago.

Download all attachments as: .zip

Change History (3)

Changed 22 months ago by akliewer99

comment:1 in reply to: ↑ description Changed 22 months ago by hasienda

  • Priority changed from high to normal
  • Resolution set to duplicate
  • Severity changed from blocker to major
  • Status changed from new to closed

Replying to akliewer99:

How to Reproduce

I completed the installation of this new plugin to my project. While performing the upgrade I received the below error.

trac-admin contacts upgrade
Error: AttributeError: ''

Yes, but we already know this for more than a year, see #9521.

I checked my phpMyAdmin and determined that the SQL statement did NOT execute.

Pretty please email me the SQL statement so I can get this plugin installed.

No, it doesn't work that way, sorry. In the aforementioned ticket you'll find more details on the issue. (Note that 0.13dev eventually became new stable Trac-1.0, released earlier this year.)

I have a fresh Trac install (only a few tickets) with some other plugins and I am using the MYSQL 5.5.28 with a freshly compiled from source Python 2.7 MySQLdb connector to a mysql database. See attached screen print of database from my phpmyadmin page.

I'm unable to access this file, because you named it with spaces in-between - not a bright idea in general. But it doesn't matter anyway, see below.

I would love to help out with any beta testing or other things I can do. My version of Eclipse isn't setup for python but it bet wouldn't take much.

Just let me know what I can do to help out!

As mentioned in #9521, the fix went into trunk development branch some months ago. No need to beta-test, because tags-0.6 is almost obsolete these days, and tags-0.7 will be released soon. Nevertheless positive feedback for MySQL would be still appreciated. But follow-up on that ticket, please.

Last note: Please don't try to pre-empt development decisions. The ticket system here is a developer issue tracker, not exactly meant for support. Consequently issue rating should be done by responsible plugin authors and maintainers too.

As the big red disclaimer already informed you before creating this ticket, the mailing list is a much better place for getting attention and support rather fast and reliably. Thanks for taking care next time.

comment:2 Changed 22 months ago by hasienda

I just recognize your possible assertion on MySQL compatibility as suggested by keywords chosen by you.

If that's true indeed, please follow-up in #4277 instead.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.