Modify

#10720 closed defect (duplicate)

ProgrammingError: operator does not exist: text = integerLINE 1: SELECT * FROM attachment WHERE id=148 ^HINT: No operator matches the given name and argument type(s). You might need to add explicit type casts.

Reported by: camel_flying@… Owned by: UnwashedMeme
Priority: normal Component: TicketMoverPlugin
Severity: normal Keywords: ticketsmove
Cc: k0s, jun66j5 Trac Release: 0.12

Description

How to Reproduce

While doing a POST operation on /ticket/move, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'c27a6808b1eaf478bdb3e028',
 'delete': u'delete',
 'project': u'AFA',
 'ticket': u'148'}

User agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:17.0) Gecko/20100101 Firefox/17.0

System Information

Trac 0.12.2
Babel 0.9.6
Docutils 0.7
Genshi 0.6
mod_python 3.3.1
psycopg2 2.4.2
Pygments 1.4
Python 2.7.2+ (default, Jul 20 2012, 22:32:25)
[GCC 4.6.1]
pytz 2010b
RPC 1.1.2-r12168
setuptools 0.6
Subversion 1.6.12 (r955767)
jQuery 1.4.2

Enabled Plugins

AutocompleteUsers 0.4.2dev-r11757
cc-selector 0.0.2
TicketExtPlugin 0.3.2-r10092
TicketMoverPlugin 0.1.1
TicketSidebarProvider 0.0-r11698
TracBuildbot 0.1.2
TracCustomFieldAdmin 0.2.8-r12166
TracDateField 1.1.0-r12118
TracPyDotOrgTheme 2.0
TracReportManager 0.1
TracSQL 0.3
TracThemeEngine 2.0.1
TracTocMacro 11.0.0.3
TracWikiPrintPlugin 1.9.2
TracWysiwyg 0.12.0.4-r11158
TracXMLRPC 1.1.2-r12168

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/local/lib/python2.7/dist-packages/TicketMoverPlugin-0.1.1-py2.7.egg/ticketmoverplugin/web_ui.py", line 100, in process_request
    new_location = tm.move(req.args['ticket'], req.authname, req.args['project'], 'delete' in req.args)
  File "/usr/local/lib/python2.7/dist-packages/TicketMoverPlugin-0.1.1-py2.7.egg/ticketmoverplugin/ticketmover.py", line 191, in move
    for row in get_all_dict(self.env, "SELECT * FROM %s WHERE %s=%s" % (table, _id, ticket_id)):
  File "/usr/local/lib/python2.7/dist-packages/TracSQLHelper-0.2.1-py2.7.egg/tracsqlhelper/__init__.py", line 51, in get_all_dict
    desc, rows = get_all(env, sql, *params);
  File "/usr/local/lib/python2.7/dist-packages/TracSQLHelper-0.2.1-py2.7.egg/tracsqlhelper/__init__.py", line 23, in __call__
    cur.execute(sql, params)
  File "/usr/local/lib/python2.7/dist-packages/Trac-0.12.2-py2.7.egg/trac/db/util.py", line 66, in execute
    return self.cursor.execute(sql)
ProgrammingError: operator does not exist: text = integer
LINE 1: SELECT * FROM attachment WHERE id=148
                                         ^
HINT:  No operator matches the given name and argument type(s). You might need to add explicit type casts.

Attachments (0)

Change History (3)

comment:1 Changed 20 months ago by rjollos

  • Component changed from SELECT A HACK to TicketMoverPlugin
  • Owner set to UnwashedMeme

comment:2 Changed 19 months ago by UnwashedMeme

This error appears to be in SQL generated by the plugin... what database system (and version) are you using?

comment:3 Changed 16 months ago by rjollos

  • Cc jun66j5 added
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7496, which reports using PostgreSQL.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from UnwashedMeme. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.