Modify

#10779 closed defect (duplicate)

"forgot your password" no more working on 0.4.2

Reported by: sdegrande Owned by: hasienda
Priority: normal Component: AccountManagerPlugin
Severity: major Keywords: password reset
Cc: rjollos Trac Release: 1.0

Description

I updated from 0.4dev (do not remember which rev) to 0.4.2, and the "forgot your password" feature is no more working: the 'password-reset' user's account attribute is set, the notification mail is sent, but I can not login with the autogenerated password.

The following patch seems to fix it, but I don't know if it's the right way to solve the issue:

  • acct_mgr/web_ui.py

     
    143143        return is_enabled(self.env, self.__class__) and \ 
    144144               self.reset_password and (self._write_check(log) != []) and \ 
    145145               is_enabled(self.env, self.store.__class__) and \ 
    146                self.store.hash_method 
     146               (self.store.hash_method is not None) 
    147147 
    148148    reset_password_enabled = property(_reset_password_enabled) 

AFAIK, the same patch would be needed on trunk.

Thanks for your great work !

Attachments (0)

Change History (2)

comment:1 Changed 19 months ago by rjollos

  • Cc rjollos added

I suspect this is a configuration issue. Could you provide the [account-manager] and [components] sections from your trac.ini?

comment:2 Changed 19 months ago by hasienda

  • Keywords password reset added
  • Resolution set to duplicate
  • Status changed from new to closed

I confess its somewhat hard to find, but it appeared to me immediately after reading the description, that this is a duplicate of #8927, just underlining the password store independence of this suspected issue.

Thanks for taking care to report it here, but follow-up over-there to improve focus on the issue, please.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hasienda. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.