Modify

Opened 2 years ago

Last modified 10 months ago

#10825 assigned defect

dot error if icons not set

Reported by: jsax Owned by: anbo
Priority: normal Component: ProjectPlanPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description (last modified by rjollos)

dot is looking for the file htdocs/images/none if an icon is not set.

I fixed it by adding and png called none to: projectplanplugin/0.11/trunk/projectplan/htdocs/images/

then adding the line:

u'images': u'none',

to the htdocsubdirmapping = { section of setup.py.

After doing python setup.py bdist_egg everything seems to work as dot can find the file none and show that when nothing is defined.

This behaviour was observed on an Ubuntu 12.04 with the standard ubuntu packages for dot 2.26.3 and trac 0.12. ProjectPlan was downloaded from the projectplan wiki download link and gave me r12566

Attachments (0)

Change History (4)

comment:1 Changed 23 months ago by ios@…

  • Owner changed from makadev to jsax

Unfortunately for me it does not work at all :/

Still the log shows following error :

Warning: No such file or directory while opening /srv/trac/ZELFA/.egg-cache/ProjectPlan-0.93.2-py2.7.egg-tmp/projectplan/htdocs/images/none
Error: No or improper image file="/srv/trac/ZELFA/.egg-cache/ProjectPlan-0.93.2-py2.7.egg-tmp/projectplan/htdocs/images/none"

setup.py section looks as following :

htdocsubdirmapping = { 
		    u'css': u'*.*',
		    u'images': u'none',
		    u'images': u'*.*',
		    u'images/*': u'*.*',
		    u'images/*/*': u'*.*',
		    u'images/*/*/*': u'*.*',
		    u'js': u'*.js',
		    #u'js': u'jquery-tooltip/*.js',
		    u'js/jquery-tablesorter': u'*.*',
		    u'js/jquery-tooltip': u'*.*',
		    u'js/jquery-tooltip/lib': u'*.js',
		    u'js/jquery-burndown': u'*.*',
		    }

Any hints?

comment:2 follow-up: Changed 23 months ago by jsax

  • Owner changed from jsax to anbo

First; any reason why you changed the owner to me as I am not a dev on projectplan? I changed it to anbo as I expect it to be a mistake to put me there and I can see makadev has not been active recently. I hope that is ok.

And now to your problem.

The log stated that the file do not exist, so:

  1. Check you file is in place in the source. For me after unpacking the full path is projectplanplugin/0.11/trunk/projectplan/htdocs/images/none.
  2. I am not sure what image formats is supported, I used a png. Check yours with file projectplanplugin/0.11/trunk/projectplan/htdocs/images/none. I got "PNG image data, 16 x 16, 8-bit/color RGBA, non-interlaced".
  3. After repacking and installing the new package, be sure it use the new one and do not use a cached version or something. I am not sure what possibilities there are. I guess you can try change the version to 0.93.3 or something in setup.py to be able to check you are really using the new version.

comment:3 in reply to: ↑ 2 Changed 22 months ago by anbo

  • Status changed from new to assigned

Replying to jsax: The "none" image was an error. I adapt the behavior in the upcoming release. However, if there exists any more problem, please report it here.

comment:4 Changed 21 months ago by rjollos

  • Description modified (diff)

Add Comment

Modify Ticket

Action
as assigned The owner will remain anbo.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.