Modify

Opened 8 years ago

Closed 7 years ago

#1100 closed defect (worksforme)

TracTags updates for latest trunk (0.11)?

Reported by: anonymous Owned by: athomas
Priority: normal Component: TagsPlugin
Severity: normal Keywords:
Cc: garyo@… Trac Release: 0.11

Description

TracTags doesn't work with the trunk (jan 15, 2007) anymore. Most of the macros fail, with this message:

'Formatter' object has no attribute 'chrome'

Some stuff works though, like the tags cloud. But there is no "Keywords" field on the ticket form, either. Is this plugin still being developed/supported? I'd be happy to help with it if needed, but I'm not an expert by any means on trac internals.

Attachments (0)

Change History (10)

comment:1 Changed 8 years ago by athomas

  • Component changed from TracHacks to TagsPlugin

Correcting component.

comment:2 Changed 8 years ago by athomas

  • Status changed from new to assigned

0.11 is still a moving target. TracTags will be ported once Trac trunk stabilises.

comment:3 Changed 8 years ago by garyo@…

  • Cc garyo@… added

Glad to hear it's not dead at least!

I know 0.11 is not stable yet :-) but I would be happy to help work on porting TracTags. Is there a todo list yet? I filed another ticket about it today.

comment:4 Changed 8 years ago by athomas

#1109 marked as a duplicate of this.

comment:5 follow-up: Changed 7 years ago by garyo@…

Just want to ping this ticket again; it's the one thing holding us back from using trac 0.11 trunk. We need tags! :-) AThomas, do you feel like the extension API has started to stabilize enough to do this work? Again, I'll be glad to help when the time comes (I'm not a trac expert but I'm a decent python hacker).

comment:6 in reply to: ↑ 5 Changed 7 years ago by aero

Replying to garyo@genarts.com:

Just want to ping this ticket again; it's the one thing holding us back from using

i agree with garyo@…. seems trac's trunk is stable.

comment:7 Changed 7 years ago by athomas

  • Summary changed from TracTags updates for latest trunk? to TracTags updates for latest trunk (0.11)?

comment:8 Changed 7 years ago by anonymous

is this plugin still alive?

comment:9 Changed 7 years ago by anonymous

Definitely! I'm using it on the trunk r5925 (August 8th) with no problems at all. AThomas updated it just before that date to make it work with the 0.11 API. I've heard a refactoring recently went into the trunk though, which may break it again; I'm happy where I am for now so haven't tested it against recent trunk builds.

comment:10 Changed 7 years ago by athomas

  • Resolution set to worksforme
  • Status changed from assigned to closed

WFM

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from athomas. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.