Modify

Opened 15 months ago

Closed 7 months ago

Last modified 6 months ago

#11057 closed defect (duplicate)

FootNote list isn't displayed when footnote is inside a table

Reported by: andrex Owned by: rjollos
Priority: normal Component: FootNoteMacro
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

I have a wiki page with one footnote, which is located inside of a table cell. Further down I add the [[FootNote]] macro.

The footnote reference (the number 1) is displayed inside the table cell. But the footnote text is never shown, no matter where I put the [[FootNote]] macro.

Attachments (0)

Change History (10)

comment:1 Changed 14 months ago by rjollos

Could you post some example markup that will help with reproducing the issue on my end? Thanks.

comment:2 Changed 7 months ago by jens.troeger@…

I have the same issue, would be great to have this fixed (soon)!

{{{#!td valign=top
This is some table cell text.[[FootNote(And a footnote.)]]
}}}

I have multiple cells in my table, some of which use that footnote macro. All are numerated with 1. and none shows up in the actual footnote collection.

comment:3 Changed 7 months ago by rjollos

I suspect that Trac needs to have the capability to expand a macro inside of a table cell. If you cannot put any other macros inside a table cell and see them expanded, then this is probably the case, and it would therefore be an issue that needs to be handled in the Trac core and can't be dealt with here.

I don't intend to invest much more time on this macro. Future effort would go towards trac:#9037.

comment:4 Changed 7 months ago by jens.troeger@…

I tried the [[Color(red,This has a red background)]] macro and it worked just fine in a td.

I'm not too hung up on that particular FootNote macro. If there is an alternative footnote solution, I'd happily use that one. But for the time being, this macro seems to be the only way?

Last edited 7 months ago by rjollos (previous) (diff)

comment:5 Changed 7 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Okay, I understand the issue now. It is a duplicate of #9211 and I'll post a patch in that ticket.

comment:6 Changed 7 months ago by jens.troeger@…

Since this footnote macro will be replaced by another Trac feature, what's the time line on that new feature? I.e. when can I expect this to work and be usable?

comment:7 Changed 7 months ago by rjollos

It is unscheduled. Unless someone else decides to implement it, I would guess that it will be 6-12 months before I do any work on it.

comment:8 Changed 6 months ago by rjollos

Did you have a chance to test the patch in #9211?

comment:9 Changed 6 months ago by anonymous

Tested, and works! Thanks.

Feel free to close this bug whenever the patch is committed.

comment:10 Changed 6 months ago by andrex

(comment:9 was mine, I hadn't logged in yet)

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.