Modify

#11064 closed defect (invalid)

breadcrumbs.css not found

Reported by: andrex Owned by: hasienda
Priority: normal Component: BreadCrumbsNavPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

breadcrumbs.css isn't found. Trac pages try to load /chrome/breadcrumbs/css/breadcrumbs.css, but it's not found, 404. The Apache log says

File does not exist: /srv/var/lib/trac/htdocs/breadcrumbs

and indeed, that file (directory) doesn't exist. /srv/var/lib/trac is my Trac environment.

BreadCrumbsNav 0.2 and 0.3dev both give the same results. Both are installed as eggs - does that matter?

Attachments (0)

Change History (1)

comment:1 Changed 15 months ago by anonymous

  • Resolution set to invalid
  • Status changed from new to closed

I'm sorry, this was caused by a misconfiguration of my web server. Instead of

Alias /chrome/common /srv/var/lib/trac/htdocs/common
Alias /chrome/site   /srv/var/lib/trac/htdocs/site

I had set

Alias /chrome  /srv/var/lib/trac/htdocs

The TracInstall guide specifically warns not to do this, because it will block resources used by plugins, which is what happened here.

I fixed my web server configuration, and the problem is solved. Sorry for the noise.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hasienda. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.