Modify

#11074 closed defect (worksforme)

Clean/New Project tries to use mastertickets table

Reported by: makadev Owned by: anbo
Priority: low Component: ProjectPlanPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

Hi anbo, ich halte es mal Englisch für den Report. :)

--

Reproduce as follows:

  • Create a new project with ProjectPlanPlugin.
  • Provoke usage of the mastertickets/legacy check
    • it should suffice to load the plugin's configuration or use a macro since ppenv invokes the check (and ppenv is used by the most - if not all - sub-components)
  • Create a new ticket
  • Use a Macro (which gets at least one Ticket)

Result:

As an example: report/gvhierarchical lines from the Examples.

Error: Macro ProjectPlan(macroid=report_buffer,renderer=report_buffer,limitlines=4) failed

no such table: mastertickets
..
Error: Macro ProjectPlan(macroid=1,renderer=gvhierarchical) failed

no such table: mastertickets

Masterticket compatibility is enabled.

exile ppptesting # cat conf/trac.ini | grep master
enable_mastertickets_compatiblity_mode = enabled

Checking the db (sqlite3) shows the legacy mode should be used.

sqlite> SELECT * FROM ticket;
1|task|1368416929241503|1368416972380224|component1||critical|admin|admin||||closed|duplicate|Invent the Wheel|Should be round|
sqlite> SELECT * FROM ticket_custom;
1|dependencies|
1|due_assign|01.01.2000
1|due_close|01.02.2000
sqlite> SELECT * FROM mastertickets;
Error: no such table: mastertickets

--

If the Mastertickets Plugin (or its Table) should be used, it may be better to enforce (and check) the use of Mastertickets since it hooks itself in the Ticketsystem.
(didn't test it but i guess it is possible to check if the plugin is enabled in the configuration section "components")

Greetings,

makadev

Attachments (0)

Change History (2)

comment:1 Changed 14 months ago by makadev

In 13300:

v2.1.4, patch release
fixed

  • b.e. ticket mode for gv renderer: b.e. tickets were still datetime objects, but due times are date objects, so comparision raises an exception
  • added authname to init for DataAccessDependenciesInCustomFields, thought currently unused
  • convert ticket_id to string for str/unicode replace
  • removed false from sqlconstraint, because sqlite (and maybe others) treats both false or FALSE identifier as column name and fails
  • corrected use_fast_save_changes check, since PPBooleanSwitchOption inherits PPSingleSelOption the result is not realy Boolean and needs to be checked against its selectables

refs #11074

comment:2 Changed 14 months ago by makadev

  • Resolution set to worksforme
  • Status changed from new to closed

So far,
with r13300 it seems fixed as long as

enable_mastertickets_compatiblity_mode = disabled
use_fast_save_changes = disabled

is set, the later allows to use ticket preview.

--

I've set up another testing trac environment with mastertickets and projectplan resulting in other issues.
Thought projectplan works (not the stream filter part, so previews for blocking/blocked tickets are missing), mastertickets doesn't and sporadically rewrites the dependencies, so ignore that last paragraph about forcing mastertickets.

closed for now

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.