Modify

Opened 8 years ago

Closed 7 years ago

#1108 closed defect (worksforme)

Authentication information not available.

Reported by: skoop Owned by: mgood
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.9

Description

As with Ticket #533, I get this error.

I have installed Trac on my DreamHost using DreamTracInstall.sh (http://wiki.dreamhost.com/index.php/DreamTracInstall) and had it working in no-time. This installer is purely aimed at initial installations.

Today, I wanted to create a second Trac env, and so I did:

trac-admin /home/skoop/trac_sites/jib initenv

I then created the new subdomain, put the .htaccess and (f)cgi files in there. I copied over the trac.ini from the first project and editted it to work for the second project. I created a new .htpasswd file with the htpasswd command, and used trac-admin to add TRAC_ADMIN permissions to the user I created in the .htpasswd file.

Trac in itself seems to function, or at least it displays all pages there are. However, when I click Login, I get

Oops...
Trac detected an internal error:

Authentication information not available.

If you think this really should work and you can reproduce it. Then you should consider to report this problem to the Trac team.

Go to http://trac.edgewall.com/ and create a new ticket where you describe the problem, how to reproduce it. Don't forget to include the python traceback found below.

TracGuide — The Trac User and Administration Guide
Python traceback

Traceback (most recent call last):
  File "/home/skoop/packages/lib/python2.3/site-packages/trac/web/fcgi_frontend.py", line 40, in _handler
    dispatch_request(req.path_info, req, env)
  File "/home/skoop/packages/lib/python2.3/site-packages/trac/web/main.py", line 139, in dispatch_request
    dispatcher.dispatch(req)
  File "/home/skoop/packages/lib/python2.3/site-packages/trac/web/main.py", line 107, in dispatch
    resp = chosen_handler.process_request(req)
  File "/home/skoop/packages/lib/python2.3/site-packages/trac/web/auth.py", line 82, in process_request
    self._do_login(req)
  File "/home/skoop/packages/lib/python2.3/site-packages/trac/web/auth.py", line 103, in _do_login
    assert req.remote_user, 'Authentication information not available.'
AssertionError: Authentication information not available.

I am unsure what else I should do to get this working. From the issues found on the main Trac site, this message seems related to an incorrect apache setup, but since I'm not using the default LoginModule I take it this change is not required? I base this assumption on the fact that the DreamTracInstall also did not change the apache configuration (as DH customers do not have access to that).

Any idea what this could be, and why it works on one site, and doesn't on the other?

Attachments (0)

Change History (6)

comment:1 Changed 8 years ago by mgood

Well, on Dreamhost I believe you could use the .htaccess file to configure authentication in Apache, but that's not needed if you want to use the AccountManager login form.

Make sure that you have both disabled the built-in Trac login module, as well as enabled the AccountManager's login module: AccountManagerPlugin#LoginModule

A word of warning about the Dreamhost install script: it installs Trac 0.9.6 which is old and unmaintained, and it seems to build a lot of packages which are already installed on Dreamhost. At some point I'll try to replace that page with some current installation instructions, but I'd recommend updating to Trac 0.10.3.

comment:2 Changed 8 years ago by skoop

Thanks so far. Indeed I did check the enabling/disabling. The trac.ini contains

[components]
acct_mgr.* = enabled
trac.web.auth.LoginModule = disabled
webadmin.* = enabled

Thanks for the heads-up about the versions, I guess I should try to upgrade.

comment:3 follow-up: Changed 8 years ago by skoop

  • Resolution set to worksforme
  • Status changed from new to closed

OK, I guess there was some kind of caching at work here (?)

I returned a few minutes ago to play with it a bit, and all of a sudden it worked! If there is any caching built-in, then that will be it, as I made the mistake of forgetting to enable the acct_mgr in the trac.ini. I added it after it turned out not to be working.

comment:4 in reply to: ↑ 3 Changed 8 years ago by mgood

Replying to skoop:

OK, I guess there was some kind of caching at work here (?)

I returned a few minutes ago to play with it a bit, and all of a sudden it worked! If there is any caching built-in, then that will be it, as I made the mistake of forgetting to enable the acct_mgr in the trac.ini. I added it after it turned out not to be working.

There's no caching, but enabling or disabling modules requires a restart of the server.

comment:5 follow-up: Changed 7 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

How can I restart the server in DreamHost?

comment:6 in reply to: ↑ 5 Changed 7 years ago by mgood

  • Resolution set to worksforme
  • Status changed from reopened to closed

Replying to anonymous:

How can I restart the server in DreamHost?

If you're using FastCGI you can kill the processes and Apache will relaunch them. If you need more help please use the t:MailingList, since there are more people to help and this is not a bug in the plugin.

Add Comment

Modify Ticket

Action
as closed The owner will remain mgood.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.