Modify

#11230 closed defect (fixed)

Could not find pdflatex binary at /usr/bin/pdflatex

Reported by: jaydub66@… Owned by: kisielk
Priority: normal Component: TracMathPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description

I want to report two problems:

  1. TracMath 0.6 seems to be triggered by any occurence of "$ ... $" in wiki pages, and not only those marked by "#!latex".
  1. I get red boxes showing "TracMath macro processor has detected an error. Please fix the problem before continuing. Could not find pdflatex binary at /usr/bin/pdflatex". This is clearly bogus since I do have a pdflatex binary at the mentioned location:

$ which pdflatex
/usr/bin/pdflatex

$ pdflatex -v
pdfTeX 3.1415926-1.40.10-2.2 (TeX Live 2009/Debian)
kpathsea version 5.0.0
Copyright 2009 Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
There is NO warranty. Redistribution of this software is
covered by the terms of both the pdfTeX copyright and
the Lesser GNU General Public License.
For more information about these matters, see the file
named COPYING and the pdfTeX source.
Primary author of pdfTeX: Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).
Compiled with libpng 1.2.46; using libpng 1.2.46
Compiled with zlib 1.2.3.4; using zlib 1.2.3.4
Compiled with poppler version 0.18.2

The trac log only shows "2013-07-18 22:06:31,551 Trac[tracmath] ERROR: Could not find pdflatex binary at /usr/bin/pdflatex".
Is there anything I can do to debug this?

System info:
Trac 1.0
TracMath 0.6
Ubuntu 12.04

Attachments (0)

Change History (1)

comment:1 Changed 13 months ago by jaydub66@…

  • Resolution set to fixed
  • Status changed from new to closed

The second point turned out to be a local installation issue in the end, and the first is probably a feature and not a bug ...

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.