Modify

Opened 10 months ago

Closed 10 months ago

Last modified 10 months ago

#11306 closed defect (duplicate)

[Patch] make sure scope is passed as an int

Reported by: korn Owned by: sandinak
Priority: normal Component: DirectoryAuthPlugin
Severity: normal Keywords:
Cc: Trac Release:

Description

-        res = d.search_s(basedn.encode(self.dir_charset), scope, lfilter, attrs)
+        res = d.search_s(basedn.encode(self.dir_charset), int(scope), lfilter, attrs)

If I specified scope in the config, the above line threw an error ("integer expected"). This trivial patch seems to fix it.

Attachments (0)

Change History (2)

comment:1 Changed 10 months ago by korn

  • Resolution set to duplicate
  • Status changed from new to closed

Sorry, duplicate of #10581.

comment:2 Changed 10 months ago by rjollos

Well, it should have been fixed a long time ago anyway. I'll push the change again now.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from sandinak. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.