Modify

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#1133 closed defect (duplicate)

Unicode error generating PDF

Reported by: mgood Owned by: athomas
Priority: normal Component: PageToPdfPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

Description copied from t:#4575

On web-page http://dev.edgcm.columbia.edu/wiki/EdGCM/UsageNotes

attempting to select the "PDF" button at the bottom, just below "Download in ohter formats:" geterates the following error:

Python Traceback

Traceback (most recent call last):
  File "/sw/lib/python2.4/site-packages/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/sw/lib/python2.4/site-packages/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/sw/lib/python2.4/site-packages/trac/wiki/web_ui.py", line 134, in process_request
    page.text, format, page.name)
  File "/sw/lib/python2.4/site-packages/trac/mimeview/api.py", line 604, in send_converted
    content, selector)
  File "/sw/lib/python2.4/site-packages/trac/mimeview/api.py", line 384, in convert_content
    output = converter.convert_content(req, mimetype, content, ck)
  File "build/bdist.darwin-8.8.0-Power_Macintosh/egg/pagetopdf/pagetopdf.py", line 20, in convert_content
  File "/sw/lib/python2.4/encodings/iso8859_15.py", line 18, in encode
    return codecs.charmap_encode(input,errors,encoding_map)
UnicodeEncodeError: 'charmap' codec can't encode character u'\u2019' in position 1764: character maps to <undefined>

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by athomas

  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 Changed 7 years ago by mankoff

The page that opened this ticket does not appear to be a dupe of #841, which discusses accents. Why is this a dupe? And what can I do to avoid this bug?

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from athomas. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.