Modify

Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#11452 closed defect (invalid)

Wiki Formatting new line does not work with test cases

Reported by: danimand Owned by: seccanj
Priority: normal Component: TestManagerForTracPlugin
Severity: normal Keywords: wiki formatting, new line, test case
Cc: Trac Release: 1.0

Description

The test case does not comply to the standard Trac ticket formatting in all cases.

For example, it ignores new lines and [BR] must be used to force them:

Attachments (1)

TM_formatting.jpg (87.9 KB) - added by danimand 7 months ago.
trac ticket vs TM test case formatting

Download all attachments as: .zip

Change History (4)

Changed 7 months ago by danimand

trac ticket vs TM test case formatting

comment:1 Changed 7 months ago by danimand

trac ticket vs TM test case formatting

comment:2 Changed 7 months ago by seccanj

  • Resolution set to invalid
  • Status changed from new to closed

This problem is not related ot the Test Manager plugin, in which the test cases are just wiki pages.

The same problem, in fact, can be found by creating a new Wiki page.

The problem is not found with tickets because carriage returns are automatically converted into "<br />"s.

I don't know why the same was not done for wiki pages.

You can see this by examining the HTML generated for ticket description as opposed to that generated for wiki pages, using the same text.

comment:3 Changed 7 months ago by rjollos

I've also wondered why the behavior differs for tickets and wiki pages. Ticket templates have the parameter escape_newlines=preserve_newlines in the call to wiki_to_html (see here and here).

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from seccanj. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.