Modify

Opened 7 months ago

Closed 7 months ago

#11519 closed defect (invalid)

SMTPAuthenticationError: (454, 'Error: authentication failed, system busy')

Reported by: jackid.wang@… Owned by: hasienda
Priority: normal Component: AccountManagerPlugin
Severity: critical Keywords: sendemail notification
Cc: Trac Release: 1.0

Description

How to Reproduce

While doing a POST operation on /admin/accounts/users, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'cead7f00ce397e846d1291f3',
 'cat_id': u'accounts',
 'change': u' Change ',
 'email': u'jackid.wang@ayijidi.com',
 'name': u'',
 'panel_id': u'users',
 'password': u'123',
 'password_confirm': u'123',
 'path_info': None,
 'username': u'admin'}

User agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36

System Information

Trac 1.0.1
Babel 0.9.4
Genshi 0.7 (without speedups)
Pygments 1.1.1
pysqlite 2.4.1
Python 2.6.6 (r266:84292, Nov 22 2013, 12:16:22)
[GCC 4.4.7 20120313 (Red Hat 4.4.7-4)]
pytz 2010h
setuptools 0.6
SQLite 3.6.20
Subversion 1.6.11 (r934486)
jQuery 1.7.2

Enabled Plugins

IniAdmin 0.3
SvnAuthzAdminPlugin 0.2
TracAccountManager 0.4.3

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/Trac-1.0.1-py2.6.egg/trac/web/main.py", line 497, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.6/site-packages/Trac-1.0.1-py2.6.egg/trac/web/main.py", line 214, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.6/site-packages/Trac-1.0.1-py2.6.egg/trac/admin/web_ui.py", line 125, in process_request
    path_info)
  File "build/bdist.linux-x86_64/egg/acct_mgr/admin.py", line 204, in render_admin_panel
    return self._do_users(req)
  File "build/bdist.linux-x86_64/egg/acct_mgr/admin.py", line 420, in _do_users
    acctmgr.set_password(username, password)
  File "build/bdist.linux-x86_64/egg/acct_mgr/api.py", line 248, in set_password
    self._notify('password_changed', user, password)
  File "build/bdist.linux-x86_64/egg/acct_mgr/api.py", line 393, in _notify
    getattr(listener, mod)(*args)
  File "build/bdist.linux-x86_64/egg/acct_mgr/notification.py", line 42, in user_password_changed
    notifier.notify(username, 'Password reset for user')
  File "build/bdist.linux-x86_64/egg/acct_mgr/notification.py", line 87, in notify
    NotifyEmail.notify(self, username, subject)
  File "/usr/lib/python2.6/site-packages/Trac-1.0.1-py2.6.egg/trac/notification.py", line 344, in notify
    Notify.notify(self, resid)
  File "/usr/lib/python2.6/site-packages/Trac-1.0.1-py2.6.egg/trac/notification.py", line 232, in notify
    self.send(torcpts, ccrcpts)
  File "/usr/lib/python2.6/site-packages/Trac-1.0.1-py2.6.egg/trac/notification.py", line 483, in send
    msg.as_string())
  File "/usr/lib/python2.6/site-packages/Trac-1.0.1-py2.6.egg/trac/notification.py", line 125, in send_email
    self.email_sender.send(from_addr, recipients, message)
  File "/usr/lib/python2.6/site-packages/Trac-1.0.1-py2.6.egg/trac/notification.py", line 165, in send
    self.smtp_password.encode('utf-8'))
  File "/usr/lib64/python2.6/smtplib.py", line 589, in login
    raise SMTPAuthenticationError(code, resp)
SMTPAuthenticationError: (454, 'Error: authentication failed, system busy')

Attachments (0)

Change History (2)

comment:1 Changed 7 months ago by rjollos

  • Component changed from SELECT A HACK to AccountManagerPlugin
  • Owner set to hasienda

This is probably an InstallationIssue.

comment:2 Changed 7 months ago by hasienda

  • Keywords notification added
  • Priority changed from highest to normal
  • Resolution set to invalid
  • Status changed from new to closed

Nice, but some additional description from the reporter is always appreciated, isn'tit? Sometimes it is crucial for success and prevents investing excessive amounts of time at developers side. Therefor I do already need to switch to plan B initially: reading the excellent Python traceback.

  1. You POSTed a password change from current stable AcctMgr user admin panel. Btw, thanks for using a recent plugin version.
  2. Likely because you configured account change notification, it triggers a notification action going into t:TracNotification system. Btw, thanks for putting contact email into this report too, so it is more likely to get this information back to you.
  3. The legacy Trac notification code utilized Python native smtplib, that raises the SMTPAuthenticationError due to not getting authenticated for the transmission to the mail server.

In short, it is a local configuration issue of Trac or mail server.

In absence of more information there is only one, superstitious way left: mode X or "glass bowl" investigation. ;-)

  1. You need to check your [notification] in trac.ini, especially configuration options 'smtp_user' and 'smtp_password'.
  2. You need to dig into you mail server authentication log for the exact authentication failure reason, and will likely find help for more successful configuration.

Note 1: You would have better asked at 'trac-users' t:MailingList, so this explanation would help more users following you instead of rotting in this closed ticket comments, you see?
Note 2: Development code has been altered to not allow notification issues to surface to non-admin users, just get logged.

Good luck, and make sure to contact us via list next time, please. We'll be happy to help there too, even confirm a plugin issue, if it really exists. Thanks for taking care.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.