Modify

Opened 6 months ago

Last modified 4 months ago

#11634 reopened defect

Create a NEW ticket -> rescheduleTickets OperationalError: near ",": syntax error

Reported by: jamescook Owned by: ChrisNelson
Priority: normal Component: TracJsGanttPlugin
Severity: normal Keywords:
Cc: Trac Release: 1.0

Description (last modified by rjollos)

I get this error when creating a new ticket (with empty Dates etc.)

tracjsgantt.tracpm.ticketrescheduler = enabled   

This error has been reported is some ways in the past:

But I can't see a solution to the Problem beyond:

tracjsgantt.tracpm.ticketrescheduler = disabled   

My question is, is there a solution to this Problem and what exactly am I losing by disabling tracjsgantt.tracpm.ticketrescheduler

The error report:

Oops…
Trac detected an internal error:

OperationalError: near ",": syntax error

This is probably a local installation issue.
Found a bug in Trac?

If you think this should work and you can reproduce the problem, you should consider creating a bug report.

Note that the Trac-jsGantt plugin seems to be involved. Please report this issue to the plugin maintainer.

Before you do that, though, please first try searching for similar issues, as it is quite likely that this problem has been reported before. For questions about installation and configuration of Trac or its plugins, please try the mailing list instead of creating a ticket.

Otherwise, please a new bug report describing the problem and explain how to reproduce it.
Python traceback
Most recent call last:

    File "/usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg/trac/web/main.py", line 497, in _dispatch_request
    File "/usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg/trac/web/main.py", line 214, in dispatch
    File "/usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg/trac/ticket/web_ui.py", line 180, in process_request
    File "/usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg/trac/ticket/web_ui.py", line 465, in _process_newticket_request
    File "/usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg/trac/ticket/web_ui.py", line 1289, in _do_create
    File "/usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg/trac/ticket/model.py", line 256, in insert
    File "/usr/local/lib/python2.7/dist-packages/Trac_jsGantt-0.10_r13705-py2.7.egg/tracjsgantt/tracpm.py", line 2950, in ticket_created
    File "/usr/local/lib/python2.7/dist-packages/Trac_jsGantt-0.10_r13705-py2.7.egg/tracjsgantt/tracpm.py", line 2917, in rescheduleTickets
    File "/usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg/trac/db/util.py", line 65, in execute
    File "/usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg/trac/db/sqlite_backend.py", line 78, in execute
    File "/usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg/trac/db/sqlite_backend.py", line 56, in execute
    File "/usr/local/lib/python2.7/dist-packages/Trac-1.0.1-py2.7.egg/trac/db/sqlite_backend.py", line 48, in _rollback_on_error

System information:

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0
Trac 	1.0.1
Babel 	0.9.6
Docutils 	0.8.1
Genshi 	0.6 (with speedups)
mod_wsgi 	3.3 (WSGIProcessGroup WSGIApplicationGroup %{GLOBAL})
Pygments 	1.4
pysqlite 	2.6.0
Python 	2.7.3 (default, Feb 27 2014, 20:09:21) [GCC 4.6.3]
pytz 	2011k
setuptools 	3.2
SQLite 	3.7.9
Subversion 	1.6.17 (r1128011)
jQuery	1.7.2
Enabled plugins:
timingandestimationplugin 	1.3.7b 	/usr/local/lib/python2.7/dist-packages/timingandestimationplugin-1.3.7b-py2.7.egg
Trac-jsGantt 	0.10-r13705 	/usr/local/lib/python2.7/dist-packages/Trac_jsGantt-0.10_r13705-py2.7.egg
TracDateField 	3.0.0dev-r12118 	/usr/local/lib/python2.7/dist-packages/TracDateField-3.0.0dev_r12118-py2.7.egg
TracMasterTickets 	3.0.5dev-r13684 	/usr/local/lib/python2.7/dist-packages/TracMasterTickets-3.0.5dev_r13684-py2.7.egg
TracSubTicketsPlugin 	0.2.0.dev-20140315 	/usr/local/lib/python2.7/dist-packages/TracSubTicketsPlugin-0.2.0.dev_20140315-py2.7.egg

Attachments (0)

Change History (11)

comment:1 Changed 6 months ago by jamescook

Should read:
I get this error when creating a new ticket (with empty Dates etc.) AND

tracjsgantt.tracpm.ticketrescheduler = enabled
Last edited 6 months ago by rjollos (previous) (diff)

comment:2 Changed 6 months ago by rjollos

  • Description modified (diff)

comment:3 Changed 5 months ago by ChrisNelson

Can you post the [TracPM] section of trac.ini? Also, do you see this at the most recent version? I made significant changes in the rescheduler recently and pushed them to T-H in the past few days.

comment:4 Changed 5 months ago by ChrisNelson

  • Resolution set to worksforme
  • Status changed from new to closed

With no more information available, I'm going to close this. Reopen if you have something to report. Thanks.

comment:5 Changed 4 months ago by jamescook

Here (at last!) is the information requested:

[TracPM]
date_format = %Y-%m-%d
default_estimate = 4.0
estimate_pad = 0.0
fields.estimate = estimatedhours
fields.finish = userfinish
fields.parent = parents
fields.percent = complete
fields.pred = blockedby
fields.start = userstart
fields.succ = blocking
fields.worked = totalhours
goal_ticket_type = milestone
hours_per_estimate = 1


Versions:

Trac 1.0.1

Integrated SCM, wiki, issue tracker and project environment
timingandestimationplugin 1.3.7b

Plugin to make Trac support time estimation and tracking with permissions
Trac-jsGantt 0.10-r13705

Trac plugin displaying jsGantt charts in Trac
TracDateField 3.0.0dev-r12118

Add custom date fields to Trac tickets.
TracDragDrop 0.12.0.12-r13613

Add drag-and-drop attachments feature to Trac
TracGanttCalendarPlugin 0.6.2

Provide calendar and ganttchart.
TracMasterTickets 3.0.5dev-r13684

Provides support for ticket dependencies and master tickets.
TracSubTicketsPlugin 0.2.0.dev-20140315

Trac Sub-Tickets Plugin
TracXMLRPC 1.1.2-r13776


comment:6 Changed 4 months ago by jamescook

As noted before, I don't get an error when

tracjsgantt.tracpm.ticketrescheduler = disabled

My main question was if disabling this feature was a big problem - what does it do?

Last edited 4 months ago by jamescook (previous) (diff)

comment:7 Changed 4 months ago by jamescook

  • Resolution worksforme deleted
  • Status changed from closed to reopened
Last edited 4 months ago by jamescook (previous) (diff)

comment:8 Changed 4 months ago by jamescook

See asked for TracPM settings above

comment:9 follow-up: Changed 4 months ago by jamescook

Moved to Postgres overnight.
Set

tracjsgantt.tracpm.ticketrescheduler = enabled

Seems error no longer occurs - setting up numerous dummy tasks with various blocking/blocked by combinations.

The error https://trac-hacks.org/ticket/11139 was also with sqlite - the issue seems to be there.

What did I lose by setting

tracjsgantt.tracpm.ticketrescheduler = disabled

while the db was sqlite.

comment:10 Changed 4 months ago by jamescook

double post

Last edited 4 months ago by jamescook (previous) (diff)

comment:11 in reply to: ↑ 9 Changed 4 months ago by ChrisNelson

Replying to jamescook:

Moved to Postgres overnight.
Set

tracjsgantt.tracpm.ticketrescheduler = enabled

Seems error no longer occurs - setting up numerous dummy tasks with various blocking/blocked by combinations.

The error https://trac-hacks.org/ticket/11139 was also with sqlite - the issue seems to be there.

What did I lose by setting

tracjsgantt.tracpm.ticketrescheduler = disabled

while the db was sqlite.

James, I'm happy to see you using the plugin. I'm not sure anyone else (besides me) is accessing the schedule and schedule_change tables to you're in unexplored territory. ;-) Sorry I wasn't able to provide more support over the long weekend; I didn't have my laptop at home.

You will have lost any potential updates to schedule_change but schedule should be fully populated on every event (ticket change) that causes the schedule to change.

Add Comment

Modify Ticket

Action
as reopened .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.