Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1188 closed defect (invalid)

csv macro can't work under freebsd 6.2 python 2.4.3

Reported by: dlin.tw@… Owned by: athomas
Priority: normal Component: CsvMacro
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

  File "/usr/local/lib/python2.4/site-packages/trac/wiki/macros.py", line 459, in render_macro
    return module.execute(req and req.hdf, content, self.env)
  File "/trac/tfx/wiki-macros/csv.py", line 6, in execute
    sniffer = csv.Sniffer()
AttributeError: 'module' object has no attribute 'Sniffer'

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by athomas

  • Resolution set to invalid
  • Status changed from new to closed

csv.Sniffer is part of the standard Python modules. If the macro can't find this object, something else is going on. Perhaps there is another csv module in the PYTHONPATH, or an old .pyc lying around. Either way, this is not a bug with CsvMacro.

comment:2 Changed 8 years ago by dlin.tw@…

I found the problem is caused by the CSV.py must be uppercase to CSV.py, I miss typo to lowercase.

Add Comment

Modify Ticket

Action
as closed The owner will remain athomas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.