Modify

Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1191 closed defect (invalid)

Revtree crashing after install under Trac 0.10.3

Reported by: chad@… Owned by: eblot
Priority: normal Component: RevtreePlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

I've just installed revtree and gotten it showing up in the nav bar. When I go to its page, I get the following python dump after 10-15 seconds. The trac log file shows the revtree eggs being loaded and no errors. The web pages has an Oops from trac with an internal error, then the following dump. The repository has few branches but lots of tags.

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.3/site-packages/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.3/site-packages/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-i686/egg/revtree/web_ui.py", line 186, in process_request
  File "build/bdist.linux-i686/egg/revtree/web_ui.py", line 314, in _process_revtree
  File "build/bdist.linux-i686/egg/revtree/model.py", line 309, in build
  File "build/bdist.linux-i686/egg/revtree/model.py", line 55, in build
  File "build/bdist.linux-i686/egg/revtree/model.py", line 83, in _find_simple_branch
StopIteration

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by anonymous

  • Resolution set to invalid
  • Status changed from new to closed

This crash appears to be related to the trac timeout. Increasing the timeout improved things. I just think my repository is a little big for this tool.

comment:2 Changed 8 years ago by eblot

How long are your branches (how many changesets / branch) ?

I'm using it w/ over 300 displayed changesets (15 branches, 20 revisions/branch) and it takes less than 5 seconds to render.

comment:3 Changed 8 years ago by chad@…

We have 101 branches. Each branch has only a few versions on it. The trunk branch has over 20k revisions. This repository was imported from CVS, so I've had lots of trouble with revtree getting confused. cvs2svn does some really strange stuff.

comment:4 Changed 8 years ago by eblot

Well, csv2svn might be the root cause of the issue, indeed.

RevtreePlugin assumes that one revision contains changes in a single branch - and only one. If it's not the case, RevtreePlugin may not work, or behave badly.

If your usage of SVN is different, RevtreePlugin is pretty much useless here.

Note that you can tell RevtreePlugin to ignore old revisions: if you follow the one changeset - one branch rule now that the import from CVS is done, simply tell RevtreePlugin not to consider all the revisions that have been imported.

Add Comment

Modify Ticket

Action
as closed The owner will remain eblot.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.