Modify

Opened 4 months ago

Closed 4 months ago

#11960 closed defect (fixed)

Changed CDN address, alternative implementation not working anymore

Reported by: Martin Schulze <spam.martin.schulze@…> Owned by: kisielk
Priority: normal Component: TracMathJaxPlugin
Severity: critical Keywords:
Cc: Trac Release:

Description

The CDN address used by both implementations differs from the "official" address which is

https://cdn.mathjax.org/mathjax/latest/MathJax.js

The old address still seems to work but not with the GET option of the alternative implementation:

https://c328740.ssl.cf1.rackcdn.com/mathjax/latest/MathJax.js?delayStartupUntil=configured

returns

<html><h1>Not Found</h1><p>The resource could not be found.</p></html>

Removing delayStartupUntil=configured option results in the link providing a more sensible document.

Attachments (0)

Change History (6)

comment:1 Changed 4 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of GitHub issue #1.

comment:2 Changed 4 months ago by Martin Schulze <spam.martin.schulze@…>

While the problem only occurs on the alternative implementation (whose tracker is on github) I found that the "normal" implementation which links its issues here does use the wrong URL. Taken from here:

NOTE: The direct Rackspace address will be retired on July 31, 2014. If you have been using the address https://c328740.ssl.cf1.rackcdn.com/… you should switch to https://cdn.mathjax.org/

I would recommend to apply this change as there is no guarantee for the old URL to continue working. (I don't know if this should be posted to bitbucket, if so that should be marked on the Wiki page for this plugin!)

comment:3 Changed 4 months ago by rjollos

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Sorry, I misread the wiki page and didn't realize that the GitHub implementation was separately maintained.

comment:4 Changed 4 months ago by Martin Schulze <spam.martin.schulze@…>

The priority should be increased (I cannot do that): The old link is dysfunctional now. This means the plugin is not working anymore.

comment:5 Changed 4 months ago by kisielk

Sorry for the trouble, I just got back from holidays today. I will put in a fix ASAP.

comment:6 Changed 4 months ago by kisielk

  • Resolution set to fixed
  • Status changed from reopened to closed

I pushed version 0.4 of the plugin which now uses the official MathJax CDN URL. Please let me know if there are any further problems.

Add Comment

Modify Ticket

Action
as closed The owner will remain kisielk.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.