Modify

Opened 7 years ago

Closed 4 years ago

#1353 closed defect (duplicate)

Crashes when encountering any file or directory that is not a project

Reported by: trevor@… Owned by: coderanger
Priority: normal Component: ProjectMenuPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

The plugin crashes when encountering any file or directory that is not a project containing a proper VERSION file. The "Available Projects" section at the root url ignores these miscellaneous files and directories (such as extra-templates and scripts for creating new Trac instances).

Traceback (most recent call last):
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 387, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 208, in dispatch
    chrome.populate_hdf(req, chosen_handler)
  File "/usr/local/lib/python2.4/site-packages/trac/web/chrome.py", line 319, in populate_hdf
    for category, name, text in contributor.get_navigation_items(req):
  File "build/bdist.solaris-2.10-sun4u/egg/projectmenu/web_ui.py", line 21, in get_navigation_items
  File "/usr/local/lib/python2.4/site-packages/trac/web/main.py", line 58, in _open_environment
    env_cache[env_path] = open_environment(env_path)
  File "/usr/local/lib/python2.4/site-packages/trac/env.py", line 434, in open_environment
    env = Environment(env_path)
  File "/usr/local/lib/python2.4/site-packages/trac/env.py", line 126, in __init__
    self.verify()
  File "/usr/local/lib/python2.4/site-packages/trac/env.py", line 174, in verify
    fd = open(os.path.join(self.path, 'VERSION'), 'r')
IOError: [Errno 20] Not a directory: '/web/trac/.htdigest/VERSION'

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by AdrianFritz

  • Resolution set to duplicate
  • Status changed from new to closed

Seems to be a duplicate of #1301, which have a [PATCH]. Please reopen if different case.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from coderanger. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.