Modify

Opened 8 years ago

Last modified 3 years ago

#1483 assigned defect

Issue with upgrading

Reported by: anonymous Owned by: masariello
Priority: normal Component: ScrumPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

Hi there,

I'm unable to run the upgrade from within my trac-admin for this component.

When I run: upgrade --no-backup Command failed: current transaction is aborted, commands ignored until end of transaction block

I run on Trac 0.10.2 / Apache 2.0.44 / Ubuntu 6.10 / Postgres 8.1.8

Thank you

Attachments (0)

Change History (9)

comment:1 Changed 8 years ago by masariello

Unfortunately I use WinXP so I don't think I'll be able to do much for you on Linux What do the trac log files say?

comment:2 Changed 8 years ago by epearson@…

I'm getting the same issue -- this is the error I see when trying to to the upgrade:

[root@Galactica conf]# trac-admin /data/trac upgrade --no-backup
Command failed: current transaction is aborted, commands ignored until end of 
transaction block

This is what I'm getting in the logfiles:

2007-05-26 19:50:02,788 Trac[env] WARNING: Component <scrumplugin.scrum.ScrumComponent 
object at 0xb78996cc> requires environment upgrade
2007-05-26 19:50:02,795 Trac[scrum] INFO: Adding column 'started' to the milestone 
table...

I'm running Trac, 0.10.4 with Postgres 8.1.4.

comment:3 Changed 7 years ago by paazio

I get while upgrading after enabling this plugin:

Command failed: (1064, "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'FUNCTION trac_date(seconds int4)\n RETURNS timestamp AS\n $BOD' at line 1")

scrumplugin from svn today Trac 0.10.5dev Fedora core 6

comment:4 Changed 7 years ago by paazio

Hups...

MySQL version 5.0.27

comment:5 Changed 7 years ago by Pramila

I am using sqlite as database. I could enable plugin but got following error while upgrade

Command failed: near "CONSTRAINT": syntax error

any workaround ?

comment:6 Changed 7 years ago by rdunlap

Pramila (and others like myself who come looking) -- Based on the information here and some poking around the plugin source code, I don't believe SQLite is currently supported. Both the "CREATE OR REPLACE" clause and the FUNCTION keyword are not found in the SQL understood by SQLite, for starters.

This is not an enhancement request -- just an observation.

comment:7 Changed 7 years ago by anonymous

People, I have no time to support the plugin these days (as I wrote on the plugin page) I'd be happy to give you write access to the code repo. Do you know how I can do that without giving you my password for the trac-hacks account?

comment:8 Changed 7 years ago by masariello

the previous message was from me (masariello)...Trac auth seems to be all messed up over here

comment:9 Changed 4 years ago by osimons

  • Cc anonymous added; Madrid removed
  • Keywords tsjgqbcjglvknlyyreen http://www.for-u-free.com/free-gifts/great-free-baby-gift-card-offer/ Baby Gift Card TjLWxvP. removed
  • Reporter changed from cbillen@… to anonymous

Sorry to all that get mails from this ticket - it is targeted for major spam attack...

Add Comment

Modify Ticket

Action
as assigned The owner will remain masariello.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.