Modify

Opened 7 years ago

Closed 7 years ago

#1580 closed defect (fixed)

Trac server URL doesn't permit non-standard ports

Reported by: epearson@… Owned by: merlimat
Priority: normal Component: EclipseTracPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

When I try to enter a port number other than 80 in the dialog to add a connection to a trac server, when entering a value such as:

http://host:8080/trac

I can't connect to the server. It should permit alternate ports to be specified.

Thanks!

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by anonymous

I think I mis-diagnosed this issue. My problem is that I can't connect through an
SSH tunnel to the trac server. Here's what I have verified:

  • I have XmlRpc and TracRpcExt plugins installed successfully
  • Accessing through the tunnel works fine from the browser
  • Accessing the trac server from the Eclipse plugin works fine when accessed directly
  • I can't connect using forwarded ports (e.g. http://localhost:1234/trac)
  • I set up the MS loopback adapter and tried through that (e.g. http://10.0.0.1/trac), and this didn't work either, so it doesn't appear to be a port issue, as I originally thought.

It seems that the plugin is being confused by something the tunnel is doing with the socket
traffic.

comment:2 Changed 7 years ago by merlimat

  • Status changed from new to assigned

Please check again with new version (1.0.4) and tell me if the problem persists.

comment:3 Changed 7 years ago by epearson@…

  • Resolution set to fixed
  • Status changed from assigned to closed

After updating to latest, the problem is resolved. Also manual validation button vs. auto validate on user typing into server URL field is a much nicer user experience. Thanks!

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from merlimat. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.