Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1635 closed defect (duplicate)

Traceback : Incoherent path [trunk] != [tags] rev: 1025

Reported by: mqm@… Owned by: eblot
Priority: normal Component: RevtreePlugin
Severity: normal Keywords: cvs2svn, cvs, incoherent, path
Cc: Trac Release: 0.10

Description

I have a CVS repository which I converted to Subversion using cvs2svn. Things worked fine, but when I installed your plugin/hack I get this error:

Python Traceback

Traceback (most recent call last):

File "C:\Python24\lib\site-packages\trac\web\main.py", line 387, in dispatch_request

dispatcher.dispatch(req)

File "C:\Python24\lib\site-packages\trac\web\main.py", line 237, in dispatch

resp = chosen_handler.process_request(req)

File "build\bdist.win32\egg\revtree\web_ui.py", line 186, in process_request
File "build\bdist.win32\egg\revtree\web_ui.py", line 314, in _process_revtree
File "build\bdist.win32\egg\revtree\model.py", line 309, in build
File "build\bdist.win32\egg\revtree\model.py", line 58, in build

AssertionError: Incoherent path [trunk] != [tags] rev: 1025

Now, is that a bug in your hack or in the way cvs2svn imported things? How can I find out?

Attachments (0)

Change History (2)

comment:1 in reply to: ↑ description Changed 7 years ago by eblot

  • Resolution set to duplicate
  • Status changed from new to closed

Replying to mqm@sglebs.com:

Now, is that a bug in your hack or in the way cvs2svn imported things? How can I find out?

This is not a hack, this is a plugin.

Short answer: the main condition for the plugin to be able to build a graph is that a single changeset should not contain changes that impact files in different branches.

If this condition is not satisfied, the plugin won't work for Trac 0.10. However, the plugin version for Trac 0.11 is more permissive and simply ignore changesets that do not comply with this rule instead of throwing an error. If your original CVS repository (or the way csv2svn works...) has created many changesets of this kind, I would recommend that you use the revbase option to force the plugin not to evaluate changesets imported from CVS and to consider only those which have been created in Subversion.

Anyway, this is a duplicate of #1090 (check out the last comments for more details)

comment:2 Changed 7 years ago by mqm@…

Sorry for the nomenclature mismatch (plugin). The name "trac hacks" on the site does not help.

I ran

svn log -v -r 1025 http://192.168.3.7/svn/carrot > svn.log

and I can't see the problem. Can you provide me with an email address I can send it to? It's just 20 lines of text but I don't want to make them public. Thanks.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from eblot. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.