Modify

Opened 8 years ago

Closed 8 years ago

#1666 closed enhancement (duplicate)

Create a desktop app to record time spend on a given task and update ticket when done

Reported by: coling Owned by: bobbysmith007
Priority: normal Component: TimingAndEstimationPlugin
Severity: trivial Keywords: desktop integration
Cc: Trac Release: 0.10

Description

This plugin would be make a lot more useful by creating a desktop application (python-gtk? or for OSX or it's clone Vista, as a Widget or Gadget).

This would simply allow starting and stopping work on a given task and the time spend therein recorded locally. Little warnings would flash up periodically (e.g. every 15 minutes - configurable) to remind the user they are still working on this ticket - I get easily distracted ;)

Once the user clicks "stop", they will be asked if they want to submit now, and if so they have to enter in a brief description of what they have done. If they choose not to, the time will be cached locally until a later date.

This will make use of the XMLRPC interface and as such may need changes to the plugin itself (I am unsure of the technical details here).

I will start work on this in the near(ish) future as I think this kind of recording app would be of great benefit in our company.

My goal is for a cross platform tool as we have people running Linux, OSX and Windows in my organisation. It would need to support HTTP level authentication of the XMLRPC side of things.

Comments/suggestions welcome.

It may come in the form of a Qt App as I need to learn more about that and I'm quite happy in C++ but any other implementation suggestions are welcome (e.g. if python-gtk is a good option I'd like to look into it - Not got any epxerience of running such apps on Windows or OSX tho').

Col

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by coling

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1667 - server errors blamed in shock duplicate posting scandal.

Add Comment

Modify Ticket

Action
as closed The owner will remain bobbysmith007.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.