Modify

Opened 7 years ago

Closed 7 years ago

#1769 closed defect (fixed)

Error when going to the worklog page

Reported by: bobbysmith007 Owned by: coling
Priority: normal Component: WorkLogPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

I get the following error whenever I go to the work log page. I checked, and I do have work recorded in the work_log table, perhaps because the key is unicode and the key in the database is ascii they are having trouble matching?

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-i686/egg/worklog/webui.py", line 114, in process_request
  File "build/bdist.linux-i686/egg/worklog/webui.py", line 65, in get_worklog
KeyError: u'russ'

Also, I am not really a fan of the auto redirecting away from the ticket I am working on whenever I click the stop or start button. Mostly, the first thing I want to do upon starting a ticket is click that button, then start trying to digest the problem at hand. Unfortunately, I currently get shuttled away to a page that doesn't actually have any info I particularly care about while attempting to solve the ticket.

Just my 2cents, I haven't actually been able to see what the worklog page provides yet since it always errors.

Thanks,

Russ

Attachments (0)

Change History (5)

comment:1 Changed 7 years ago by coling

  • Status changed from new to assigned

Cheers for the Report Russ I'll look into it.

I think I agree with you re: the start work and navigate away page. There is a very simple link on the worklog page when it's visible ;)

Out of curiosity what does your session table contain? I do a lookup to get user->Real Name mapping which is perhaps why it's failing .... e.g. if you don't have a name entered in in the Settings link in trac..... I'll try and reproduce it anyway.

Cheers

comment:2 Changed 7 years ago by coling

Yeah looking at the code, it'll break if you don't have a real name filled in.

Not ideal. I'll look into making that better ;)

Also I meant the session_attribute table but it's not needed now. I can see from the code it would fail.

comment:3 Changed 7 years ago by bobbysmith007

I definitely have not entered my name in the settings on any of my tracs (I am the only russ around, so my screen name has always been sufficient). I also checked both tables with neither containing anything that looked like what you wanted.

Also, it doesn't seem to be adding times for T&E. After I diddle it a bit more, I might file as a separate bug.

comment:4 Changed 7 years ago by coling

I'll probably just remove the real name lookup. It's a bit pointless anyway - I can do a lookup on demand anyway, so the map is totally pointless. I'll fix this soon(ish).

As for adding time to T&E, you have to enable the setting in the WebAdmin GUI for Work Log. It should be Under "Ticket System".

I need to explain this in the User Manual which I've not updated ;)

comment:5 Changed 7 years ago by coling

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [2452]) Fixes #1769. Get rid of the usermap but still look up the full name and display it if it's there. This means that the full user list is not 'named and shamed' for not doing work, but this is probably a good thing ;)

Add Comment

Modify Ticket

Action
as closed The owner will remain coling.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.