Modify

Opened 7 years ago

Closed 7 years ago

#1793 closed defect (duplicate)

Adding comment to any file fails

Reported by: haizaar@… Owned by: Team5
Priority: high Component: PeerReviewPlugin
Severity: blocker Keywords:
Cc: pn@… Trac Release: 0.10

Description

Trac 0.10.4. Linux. Python-2.4. Firefox-2.0.0.4.

Trying to add any comment to any file, shows "add comment" dialog. But when I click "Add comment" button, the following is spit in trac logs:

2007-07-14 23:59:50,098 Trac[main] ERROR: 'unicode' object has no attribute 'filename'
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/codereview/peerReviewCommentCallback.py", line 44, in process_request
    self.createComment(req)
  File "/usr/lib/python2.4/site-packages/codereview/peerReviewCommentCallback.py", line 114, in createComment
    if upload.filename:
AttributeError: 'unicode' object has no attribute 'filename'

Attachments (1)

peerReviewCommentCallback.patch (541 bytes) - added by pn@… 7 years ago.
Patch to solve this bug on Firefox

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by pn@…

Patch to solve this bug on Firefox

comment:1 Changed 7 years ago by anonymous

  • Cc pn@… added; anonymous removed

comment:2 Changed 7 years ago by c.posluschni@…

Same problem like #1855 but this patch did not work for me.

comment:3 Changed 7 years ago by pn@…

I´ve tested the patch on a Firefox 2.0.0.6 for Mac and on a Firefox 1.5 on Linux and it works for me. My Trac version is trac-0.10.4-1.fc7 (rpm for Fedora 7) and the version of the plugin is 2.0dev.

comment:4 Changed 7 years ago by djeebus

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1727

Add Comment

Modify Ticket

Action
as closed The owner will remain Team5.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.