Modify

Opened 7 years ago

Closed 23 months ago

#2278 closed enhancement (duplicate)

Add basic authentication support

Reported by: anonymous Owned by: rjollos
Priority: normal Component: IncludeMacro
Severity: normal Keywords: remote authentication
Cc: Trac Release: 0.10

Description

Is there any way we could add basic authentication support into this include macro?

Would it involve adding code like this to it?

# create a password manager
password_mgr = urllib2.HTTPPasswordMgrWithDefaultRealm()

# Add the username and password.
# If we knew the realm, we could use it instead of ``None``.
top_level_url = "http://example.com/foo/"
password_mgr.add_password(None, top_level_url, username, password)

handler = urllib2.HTTPBasicAuthHandler(password_mgr)

# create "opener" (OpenerDirector instance)
opener = urllib2.build_opener(handler)

# use the opener to fetch a URL
opener.open(a_url)

# Install the opener.
# Now all calls to urllib2.urlopen use our opener.
urllib2.install_opener(opener)

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by rjollos

  • Summary changed from Basic authentication support to Add basic authentication support

comment:2 Changed 23 months ago by hasienda

  • Keywords remote authentication added
  • Owner changed from coderanger to rjollos

comment:3 Changed 23 months ago by hasienda

  • Resolution set to duplicate
  • Status changed from new to closed

#6879 has been transformed into a duplicate of this ticket.

It's pointing to #4743, that holds some promising code for implementing the requested feature as well.

Add Comment

Modify Ticket

Action
as closed The owner will remain rjollos.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.