Modify

Opened 9 years ago

Closed 9 years ago

#233 closed defect (fixed)

Review ID error when hitting "Approve" button

Reported by: skizye@… Owned by: Team5
Priority: normal Component: PeerReviewPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.8

Description

I get the following error when trying to "Approve" a peer review.

Review ID error Invalid review ID supplied - unable to load page.

Attachments (0)

Change History (5)

comment:1 Changed 9 years ago by coderanger

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #232

comment:2 Changed 9 years ago by Team5

  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:3 Changed 9 years ago by anonymous

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:4 Changed 9 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Trac Release set to 0.8

This is an issue in the CGI and FastCGI modules in Python. A related bug can be found here: http://projects.edgewall.com/trac/ticket/2284

The workaround is to remove the query-string arguments on the form action and replace them with hidden variables.

Example from peerReviewView.cs:

comment:5 Changed 9 years ago by Team5

  • Resolution set to fixed
  • Status changed from reopened to closed

We applied this workaround in our new version 0.3

Add Comment

Modify Ticket

Action
as closed The owner will remain Team5.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.