Modify

Opened 7 years ago

Closed 6 years ago

#2447 closed defect (invalid)

some exceptions with 0.11

Reported by: ThurnerRupert Owned by: Blackhex
Priority: normal Component: DownloadsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

i installed it yesterday (not sure if it was the final 0.11 version or not), and clicking in the admin panel gives:

TypeError: process_downloads() takes exactly 2 arguments (3 given)

File "/opt/csw/testing/lib/python/site-packages/Trac-0.11dev_r6398-py2.5.egg/trac/web/main.py", line 406, in _dispatch_request

dispatcher.dispatch(req)

File "/opt/csw/testing/lib/python/site-packages/Trac-0.11dev_r6398-py2.5.egg/trac/web/main.py", line 195, in dispatch

resp = chosen_handler.process_request(req)

File "/opt/csw/testing/lib/python/site-packages/Trac-0.11dev_r6398-py2.5.egg/trac/admin/web_ui.py", line 108, in process_request

path_info)

File "build/bdist.solaris-2.10-sun4u/egg/tracdownloads/admin.py", line 44, in render_admin_panel

now i tried to reinstall, and it gives:

# easy_install --prefix /opt/csw/testing http://trac-hacks.org/svn/downloadsplugin/0.11/
Downloading http://trac-hacks.org/svn/downloadsplugin/0.11/
Doing subversion checkout from http://trac-hacks.org/svn/downloadsplugin/0.11/ to /tmp/easy_install-Jk-dyv/0.11
Processing 0.11
Running setup.py -q bdist_egg --dist-dir /tmp/easy_install-Jk-dyv/0.11/egg-dist-tmp-OTfM8r
zip_safe flag not set; analyzing archive contents...
TracDownloads 0.2 is already the active version in easy-install.pth

Installed /opt/csw/testing/lib/python2.5/site-packages/TracDownloads-0.2-py2.5.egg
Processing dependencies for TracDownloads==0.2
Traceback (most recent call last):

File "/opt/csw/bin/easy_install", line 8, in <module>

load_entry_point('setuptools==0.6c7', 'console_scripts', 'easy_install')()

File "/opt/csw/lib/python/site-packages/easy_install.py", line 1670, in main

File "/opt/csw/lib/python/site-packages/easy_install.py", line 1659, in with_ei_usage

File "/opt/csw/lib/python/site-packages/easy_install.py", line 1674, in <lambda>

File "/opt/csw/lib/python/distutils/core.py", line 151, in setup

dist.run_commands()

File "/opt/csw/lib/python/distutils/dist.py", line 974, in run_commands

self.run_command(cmd)

File "/opt/csw/lib/python/distutils/dist.py", line 994, in run_command

cmd_obj.run()

File "/opt/csw/lib/python/site-packages/easy_install.py", line 211, in run

File "/opt/csw/lib/python/site-packages/easy_install.py", line 422, in easy_install

File "/opt/csw/lib/python/site-packages/easy_install.py", line 473, in install_item

File "/opt/csw/lib/python/site-packages/easy_install.py", line 519, in process_distribution

File "/opt/csw/lib/python/site-packages/pkg_resources.py", line 529, in resolve

requirements.extend(dist.requires(req.extras)[::-1])

File "/opt/csw/lib/python/site-packages/pkg_resources.py", line 2107, in requires

dm = self._dep_map

File "/opt/csw/lib/python/site-packages/pkg_resources.py", line 2099, in _dep_map

for extra,reqs in split_sections(self._get_metadata(name)):

File "/opt/csw/lib/python/site-packages/pkg_resources.py", line 2518, in split_sections

for line in yield_lines(s):

File "/opt/csw/lib/python/site-packages/pkg_resources.py", line 1813, in yield_lines

for ss in strs:

File "/opt/csw/lib/python/site-packages/pkg_resources.py", line 2121, in _get_metadata

for line in self.get_metadata_lines(name):

File "/opt/csw/lib/python/site-packages/pkg_resources.py", line 1140, in get_metadata_lines

return yield_lines(self.get_metadata(name))

File "/opt/csw/lib/python/site-packages/pkg_resources.py", line 1137, in get_metadata

return self._get(self._fn(self.egg_info,name))

File "/opt/csw/lib/python/site-packages/pkg_resources.py", line 1195, in _get

return self.loader.get_data(path)

zipimport.ZipImportError: bad local file header in /opt/csw/testing/lib/python2.5/site-packages/TracDownloads-0.2-py2.5.egg

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by Blackhex

I made two changesets about port to 0.11 yesterday. If the first version you've tried is not r3114, delete DownloadsPlugin files in your /opt/csw/testing/lib/python2.5/site-packages/ and install r3114 aggain. If you tried this version already (which I doubt) just let me know.

comment:2 Changed 7 years ago by Blackhex

  • Status changed from new to assigned

comment:3 Changed 6 years ago by Blackhex

  • Resolution set to invalid
  • Status changed from assigned to closed

I'm quite sure that this was caused by not finished version so I'm closing it. Reopen if does same thing with lastest revision.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from Blackhex. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.