Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#2632 closed defect (wontfix)

Tries to retrieve a non-existent object for a changeset

Reported by: jkp@… Owned by: hvr
Priority: normal Component: GitPlugin
Severity: major Keywords: sha incorrect
Cc: Trac Release: 0.11

Description

Hi there:

When trying to retreive this page: GET: /changeset/65e5795d0a77b341ecfc9d9df7a7e08fe02dc3d5
I get the following error:
Trac detected an internal error:
GitErrorSha: object '131ee778fd5757495d9807b24231111f801ed839' not found

I can't see why it is looking for that SHA...the SHA it should be looking for is specified in the URL. I've had a quick look through the plugin but I don't have the time to find the issue myself right now.

Sometimes things work right, with many changesets, but some produce an incorrect SHA lookup.

I'm on the 0.11 branch using the timeline to look at my changesets.

Attachments (0)

Change History (10)

comment:1 Changed 7 years ago by hvr

could you provide some more info please? :-)

maybe a back-trace?

is the 131eee... sha somehow related to that changeset (e.g. a parent/child/next/prev?)

comment:2 follow-up: Changed 7 years ago by jkp@…

hi there:

Sorry, I didn't see this in the log before (I had turned on debugging to see what I could find)...

008-02-25 07:29:09,705 Trac[main] DEBUG: Dispatching <Request "GET u'/changeset/65e5795d0a77b341ecfc9d9df7a7e08fe02dc3d5'">
2008-02-25 07:29:09,711 Trac[svn_fs] INFO: Failed to load Subversion bindings
Traceback (most recent call last):

File "/users/home/thekirk/python/lib/python2.5/site-packages/Trac-0.11dev_r6603-py2.5.egg/trac/versioncontrol/svn_fs.py", line 251, in init

_import_svn()

File "/users/home/thekirk/python/lib/python2.5/site-packages/Trac-0.11dev_r6603-py2.5.egg/trac/versioncontrol/svn_fs.py", line 69, in _import_svn

from svn import fs, repos, core, delta

ImportError: No module named svn
2008-02-25 07:29:09,722 Trac[git_fs] INFO: detected GIT version 1.5.3.6
2008-02-25 07:29:09,723 Trac[PyGIT] DEBUG: PyGIT.Storage instance 142814732 constructed
2008-02-25 07:29:09,723 Trac[PyGIT] DEBUG: requested weak PyGIT.Storage instance 142814732 for '/users/home/thekirk/git/prestige.git/.git'
2008-02-25 07:29:09,723 Trac[git_fs] INFO: disabled CachedRepository for '/users/home/thekirk/git/prestige.git/.git'
2008-02-25 07:29:09,737 Trac[PyGIT] DEBUG: triggered rebuild of commit tree db for 142814732
2008-02-25 07:29:10,063 Trac[PyGIT] DEBUG: rebuilt commit tree db for 142814732 with 8655 entries
2008-02-25 07:29:10,064 Trac[session] DEBUG: Retrieving session for ID '0eeb43608fc5a5da27c2b118'
2008-02-25 07:29:10,123 Trac[chrome] DEBUG: Prepare chrome data for request
2008-02-25 07:29:10,124 Trac[perm] DEBUG: No policy allowed anonymous performing TICKET_CREATE on None
2008-02-25 07:29:10,125 Trac[perm] DEBUG: No policy allowed anonymous performing TRAC_ADMIN on None
2008-02-25 07:29:10,126 Trac[perm] DEBUG: No policy allowed anonymous performing PERMISSION_GRANT on None
2008-02-25 07:29:10,126 Trac[perm] DEBUG: No policy allowed anonymous performing PERMISSION_REVOKE on None
2008-02-25 07:29:10,126 Trac[perm] DEBUG: No policy allowed anonymous performing TICKET_ADMIN on None
2008-02-25 07:29:10,598 Trac[main] ERROR: object '131ee778fd5757495d9807b24231111f801ed839' not found
Traceback (most recent call last):

File "/users/home/thekirk/python/lib/python2.5/site-packages/Trac-0.11dev_r6603-py2.5.egg/trac/web/main.py", line 419, in _dispatch_request

dispatcher.dispatch(req)

File "/users/home/thekirk/python/lib/python2.5/site-packages/Trac-0.11dev_r6603-py2.5.egg/trac/web/main.py", line 196, in dispatch

resp = chosen_handler.process_request(req)

File "/users/home/thekirk/python/lib/python2.5/site-packages/Trac-0.11dev_r6603-py2.5.egg/trac/versioncontrol/web_ui/changeset.py", line 323, in process_request

self._render_html(req, repos, chgset, restricted, xhr, data)

File "/users/home/thekirk/python/lib/python2.5/site-packages/Trac-0.11dev_r6603-py2.5.egg/trac/versioncontrol/web_ui/changeset.py", line 544, in _render_html

diff_bytes += _estimate_changes(old_node, new_node)

File "/users/home/thekirk/python/lib/python2.5/site-packages/Trac-0.11dev_r6603-py2.5.egg/trac/versioncontrol/web_ui/changeset.py", line 498, in _estimate_changes

old_size = old_node.get_content_length()

File "build/bdist.solaris-2.11-i86pc/egg/tracext/git/git_fs.py", line 349, in get_content_length

self.fs_size = self.git.get_obj_size(self.fs_sha)

And no, that changeset doesnt even exist I don't think. Here is the info for the changeset I got from git:

KidA% git cat-file commit 65e5795d0a77b341ecfc9d9df7a7e08fe02dc3d5
tree 0a718ab762b20fa6cf6a9cc37e90a7c09063136c
parent 747323490880b3dd0c384c72fbfece6c19eff406
author Jamie Kirkpatrick <jkp@…> 1203876188 +0100
committer Jamie Kirkpatrick <jkp@…> 1203876542 +0100

Hope that helps.

PS: GREAT work. I didn't mean to file two complaints in one go...just want to help you make it better :)

comment:3 Changed 7 years ago by hvr

  • Status changed from new to assigned

thanks for the traceback :-)

well, this exception is not about a revision sha, but about a blob sha, which is most likely associated with that commit...

can we rule out, that the git repository was garbage collected/pruned while GitPlugin's Instance was alive? i.e. can this be reproduced after restarting Trac with the very same changeset?

what would be git diff-tree -r -m 65e5795d0a77b341ecfc9d9df7a7e08fe02dc3d5's output?

comment:4 in reply to: ↑ 2 Changed 7 years ago by hvr

Replying to jkp@kirkconsulting.co.uk:

hi there:

Sorry, I didn't see this in the log before (I had turned on debugging to see what I could find)...

ps: next time, please enclose log output within

{{{
...logoutput...
}}}

brackets, so it doesn't get re-wrapped :-)

comment:5 follow-up: Changed 7 years ago by jkp@…

Yeah I just did that in the comment I posted, but the item was locked coz you were editing it to tell me to do that! Doh!

KidA% git diff-tree -r -m 65e5795d0a77b341ecfc9d9df7a7e08fe02dc3d5
65e5795d0a77b341ecfc9d9df7a7e08fe02dc3d5
:100644 100644 f4d5f7d7f976204b05a6b0d2e92b2ec21b44e375 2f4534bdcb965d715f745eca748357242d379eff M	Applications/PrManager/PrCrypt.cpp
:100644 100644 488e3aff3cc1c798679b97763075fdf230cb1cc2 7153c1c69d2a007671b9e333bbf7b4e77a4dc160 M	Applications/PrManager/PrDatabase.cpp
:100644 100644 0a57e338a393d7ef4129ba1599a939f6d89d1607 585f02475f23232343ce25f0010240e2bdff4d6a M	Applications/PrManager/PrDatabase.h
:100644 100644 c41a6726ca72730fe295386605db37a6d6c08d15 ec33feb12ab868d1ff1a2486d3b9d99f344dea59 M	Applications/PrManager/PrItem.cpp
:100644 100644 08084628cdc58f92dbec7ca17f65fef13c768c6a 9599eee114d0a6dab52494acec6f45ec26dc4c7b M	Applications/PrManager/PrItemData.cpp
:100644 100644 9dac2b3533369b8d7b430c1f55cceae856019bec 8359ca43d744cb4580c71f121646e1166b52db42 M	Applications/PrManager/PrItemQuery.cpp
:100644 100644 131ee778fd5757495d9807b24231111f801ed839 109fc773db08c3cfbc62add2770cb20b33e06051 M	Applications/PrManager/PrManager.cpp
:100644 100644 838a9d6798222b108fa766b4551f7ae63cf099d1 7d393f4c79b17eac1adf8c471067b28e86c7afc9 M	Applications/PrManager/PrManager.h
:100644 100644 449762901df2271bea0f5a81c4503eb86181d3d2 958c8844534f355026e1746241eefa3d5fca4258 M	Applications/PrManager/PrMulticastSender.cpp
:100644 100644 357b5726e242eaff1d2818e778c996f28930cbd4 c882b14e887a9784712c7a6aa8fd77ff4b9d2aa7 M	Applications/PrManager/PrODBCDatabase.cpp
:100644 100644 90a304f336eecf5527bce943160eef01a586284c 61ae889ca54341b9dee93cac7c53c5b9bf94a4ab M	Applications/PrManager/PrScriptJobScheduler.cpp
:100644 100644 891185405582c9aa94002cd4b279e8607e2bbd6d 069e38fc33d0be89400d318eb333339948325c93 M	Applications/PrManager/PrServer.cpp
:100644 100644 8ed1f5a83683284f0f28e7f4bdaf9fc1072db7a7 3f6bccf47015447b367c329522a2520423b65a70 M	Applications/PrManager/PrStory.cpp
:100644 100644 e377919b3616a2d36c54cdc10cf715db5201043e d28be78c8182e4f98d1f2d68daf20ea138ad5ca2 M	Applications/PrManager/PrStoryText.cpp
:100644 100644 23b590ede91519fba978399329afbb30be677b95 513ab0f62b5620ab116a0a9a9480ba75c8843c0c M	Include/PrCommon.h
:100644 100644 9cf2acbe1cd26e5203d54ecdbe0736452d7fd285 78ed5c6233a17ae4834630629f7db7562fd0ee1e M	Include/PrSignal.h
:100644 100644 5d2446b94b63f6402becf022640ab965b5048c98 80d177f6ca2c3f90bff81136cb118e08f0b0975d M	Include/PrSocket.h
:100644 100644 6b8e77fa151750d76086a6f6a01a4864e31b8761 b716c10b479653e914d2f70e2a37268c683871f3 M	Include/PrThread.h
:000000 100644 0000000000000000000000000000000000000000 ca6d1ee81da1dc9bc167b40dc7e4cfd216f7a991 A	Mac/PRManager/PRManager.xcodeproj/jkp.mode2v3
:100644 100644 b7e1d0d5273bece0787d20e41bf96b68a33d08cd 8f9eba10b4e5b9ead6ea13ea2647eeb1ce32c78a M	Mac/PRManager/PRManager.xcodeproj/jkp.pbxuser
:100644 100644 8f93c37ab28c6052406187da410849ff7172d66d 42602a12c935c792a8632a34c60460ed0af6a751 M	Mac/PRManager/PRManager.xcodeproj/jkp.perspectivev3
:100644 100644 8bad519633e1a3f4aa7737e0ac851c030689b561 1c49bc2e8dbc3847963c8c4ddc9d4f2a82493b7f M	Mac/PRManager/PRManager.xcodeproj/project.pbxproj
:100644 100644 2edb6aeb91b946ac6db30deb6a7bd61f182bcfab fd559b972894c19b444f5b2274205ce23c53e419 M	Mac/PRManager/main.cpp
:000000 100644 0000000000000000000000000000000000000000 cf4c5f11bf2b457df293a3f8e7449ec347f622e5 A	Mac/PRUtility/PRUtility.xcodeproj/jkp.mode2v3
:100644 100644 7464ebd8fb44d78b5818757bb10e66f1b7cfb153 186c8f75dbf3764501dcadf6fb9743edf745c661 M	Mac/PRUtility/PRUtility.xcodeproj/jkp.pbxuser
:100644 100644 082403bf78e22d1303e6f0b7201240238216f03c 514d9c323c8f87987699c61e9e1c063020974e2a M	Mac/PRUtility/PRUtility.xcodeproj/jkp.perspectivev3
:000000 100755 0000000000000000000000000000000000000000 888d0adbef3ac255fe3ba57ecb471e6bb3456666 A	SQL Scripts/CreatePostgresDatabase.sh
:000000 100755 0000000000000000000000000000000000000000 77589fcee3997297218c110a17cda79b09484a5a A	SQL Scripts/Prestige5_MySQL.sql
:000000 100755 0000000000000000000000000000000000000000 4492d9edf2943d6d4f9a1230b7b4d90104122488 A	SQL Scripts/Prestige5_MySQL_Data.sql
:000000 100644 0000000000000000000000000000000000000000 e57a3553cd280442903d34a9a5540a0248ad33b0 A	SQL Scripts/Prestige5_MySQL_GlobalParams.sql
:100644 100755 d23ff2f8b3157a2565acb207aae388d398ca8876 305d5f3ab16d42cb026c44838cce4f82c69fdd9c M	SQL Scripts/Prestige5_Oracle_Data.sql
:000000 100755 0000000000000000000000000000000000000000 457fbde3e12d2df5b26f14cd8cfdd6cb14ce2a57 A	SQL Scripts/Prestige5_Postgres.sql
:000000 100755 0000000000000000000000000000000000000000 516ee21cccc7003d3380b2f555dec28aae64e9eb A	SQL Scripts/Prestige5_Postgres_Data.sql
:000000 100644 0000000000000000000000000000000000000000 369e5d9ae27568ec666d6233b56afd1b8dcb8803 A	SQL Scripts/Prestige5_Postgres_GlobalParams.sql
:100644 100644 7cf6d0dd963c74a80f0433838a665397719d1fda e5c9cf4b3d946b11863b69b7a9e524973d9ee9f9 M	Shared Libraries/PrUtilityLib/PrSocket.cpp
:100644 100644 27afe0b6ddc85e93d58b713c064a9c24195ae6c9 14863c55328c86d81582a5eb97b232fade638a38 M	Shared Libraries/PrUtilityLib/PrThread.cpp

comment:6 in reply to: ↑ 5 Changed 7 years ago by hvr

Replying to jkp@kirkconsulting.co.uk:

Yeah I just did that in the comment I posted, but the item was locked coz you were editing it to tell me to do that! Doh!

:-)

well, the following one seems to be our problem... doesn't that 131ee... object exist (i.e. if you try to git cat-file blob 131ee77 or git cat-file -s 131ee77)?

:100644 100644 131ee778fd5757495d9807b24231111f801ed839 109fc773db08c3cfbc62add2770cb20b33e06051 M	Applications/PrManager/PrManager.cpp

comment:7 follow-up: Changed 7 years ago by jkp@…

Hrm. OK, so this could be the issue. If I do it on my local machine I have no issues, however on the shared-hosting I get an out of memory error. I wonder if their limits are too low for git.

Seems its not an issue with your code at all! Sorry for the wild goose chase.

comment:8 in reply to: ↑ 7 Changed 7 years ago by hvr

Replying to jkp@kirkconsulting.co.uk:

Hrm. OK, so this could be the issue. If I do it on my local machine I have no issues, however on the shared-hosting I get an out of memory error. I wonder if their limits are too low for git.

well, Trac0.11+GitPlugin do use up quite a bit of memory at the moment...

how much memory do you have at your disposal on that hosting host?

Seems its not an issue with your code at all! Sorry for the wild goose chase.

np

comment:9 Changed 7 years ago by hvr

  • Resolution set to wontfix
  • Status changed from assigned to closed

comment:10 Changed 7 years ago by jkp@…

Well, I just read that the limit is a 100MB...which seems like it should be big enough to run this command. I've filed a support request with them so I'll have to see what they come back with. Otherwise maybe I'm going to be looking at new hosting :(

(I use Textdrive's Shared Accelerator)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.