Modify

Opened 6 years ago

Closed 5 years ago

#2638 closed defect (duplicate)

IOError: Bad path: None

Reported by: anonymous Owned by: kisg
Priority: normal Component: SvnAuthzAdminPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Traceback (most recent call last):

File "C:\Python24\Lib\site-packages\trac\web\main.py", line 406, in dispatch_request

dispatcher.dispatch(req)

File "C:\Python24\Lib\site-packages\trac\web\main.py", line 237, in dispatch

resp = chosen_handler.process_request(req)

File "build\bdist.win32\egg\webadmin\web_ui.py", line 119, in process_request
File "build\bdist.win32\egg\svnauthz\admin_ui.py", line 78, in process_admin_request
File "C:\Python24\lib\nturl2path.py", line 55, in pathname2url

raise IOError, error

IOError: Bad path: None:/

trac.ini
authz_file = C:/projects/svn/main/conf/authz

Attachments (1)

SvnAuthzAdmin#2638.diff (754 bytes) - added by norbert.a.wenzel@… 6 years ago.
Workaround patch for paths like "None:/"

Download all attachments as: .zip

Change History (6)

comment:1 in reply to: ↑ description Changed 6 years ago by José Renato

Replying to José Renato:

I'm having the same problem.

Traceback (most recent call last):

File "C:\Python24\Lib\site-packages\trac\web\main.py", line 406, in dispatch_request

dispatcher.dispatch(req)

File "C:\Python24\Lib\site-packages\trac\web\main.py", line 237, in dispatch

resp = chosen_handler.process_request(req)

File "build\bdist.win32\egg\webadmin\web_ui.py", line 119, in process_request
File "build\bdist.win32\egg\svnauthz\admin_ui.py", line 78, in process_admin_request
File "C:\Python24\lib\nturl2path.py", line 55, in pathname2url

raise IOError, error

IOError: Bad path: None:/

trac.ini
authz_file = C:/projects/svn/main/conf/authz

comment:2 Changed 6 years ago by norbert.a.wenzel@…

I had the same problem here. My bad path was None:/. Did a stupid if/else workaround hack, it seems to work now. Patch is added.

Changed 6 years ago by norbert.a.wenzel@…

Workaround patch for paths like "None:/"

comment:3 Changed 5 years ago by ThurnerRupert

why this is necessary? to avoid entering authz_module_name

"None" in trac.ini?

comment:4 Changed 5 years ago by anonymous

  • Trac Release changed from 0.10 to 0.11

Python Traceback
Most recent call last:
File "d:\traclight\python\lib\site-packages\Trac-0.11.4-py2.5.egg\trac\web\main.py", line 435, in _dispatch_request
File "d:\traclight\python\lib\site-packages\Trac-0.11.4-py2.5.egg\trac\web\main.py", line 205, in dispatch
File "d:\traclight\python\lib\site-packages\Trac-0.11.4-py2.5.egg\trac\admin\web_ui.py", line 113, in process_request
File "d:\traclight\python\lib\site-packages\SvnAuthzAdminPlugin-0.1.2._Moved.to.Trac.0.11_-py2.5.egg\svnauthz\admin_ui.py", line 87, in render_admin_panel
File "D:\TracLight\python\lib\nturl2path.py", line 55, in pathname2url

Trac detected an internal error:
IOError: Bad path: SampleProject:/


System Information:

User Agent: Opera/9.64 (Windows NT 5.1; U; ja) Presto/2.1.1
Trac: 0.11.4
Python: 2.5.2 (r252:60911, Feb 21 2008, 13:11:45) [MSC v.1310 32 bit (Intel)]
setuptools: 0.6c9
SQLite: 3.3.4
pysqlite: 2.3.2
Genshi: 0.5
mod_python: 3.3.1
Pygments: 1.0
Subversion: 1.5.2 (r32768)
jQuery: 1.2.6


trac.ini
[trac]
authz_file = D:\TracLight\projects\svnauthz
authz_module_name = SampleProject

comment:5 Changed 5 years ago by ThurnerRupert

  • Resolution set to duplicate
  • Status changed from new to closed

cannot reproduce:

  1. the first example "None:/" looks like there was no
  2. the second exmple IOError: Bad path: SampleProject:/ looks like problems on windows

so i think its a duplicate of #5484 and #5302.

if not analysed correctly, pls reopen.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from kisg. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.