Modify

Opened 6 years ago

Closed 6 years ago

#2657 closed enhancement (fixed)

No comma in text

Reported by: jens.fuhrmann@… Owned by: diroussel
Priority: normal Component: ColorMacro
Severity: minor Keywords: escaping comma
Cc: simon.yang.sh@… Trac Release: 0.10

Description

You can't color the , in a text.

i.e.

[[Color(red,The ColorMacro is great! You're able to supply your text with green, yellow, blue or red background.)]]

doesn't work as one might wish to. A possibility to escape special characters would be nice to have.

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by bettse@…

change

args = tuple(args.split(","))

into

args = tuple(args.split(",",2))

Hopefully this makes it into the release soon :)

comment:2 Changed 6 years ago by diroussel

  • Cc simon.yang.sh@… added

closed ticket:2954 as a duplicate of this

comment:3 Changed 6 years ago by diroussel

  • Resolution set to fixed
  • Status changed from new to closed

fixed in changeset:4512

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from diroussel. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.