Modify

Opened 6 years ago

Closed 5 years ago

#2679 closed defect (duplicate)

Special characters in passwords provoke an internal error

Reported by: jeberger@… Owned by: mgood
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

Description

When adding a new user, if the password contains special characters Trac gives an internal error.

Steps to reproduce

  1. Go to the "Users" administration page;
  2. Create a new user, name="foo", pasword="é";

Version information

  • Trac: 0.10.4
  • TracAccountManager: 0.1.3dev
  • Python: 2.5
  • Firefox: 2.0.0.6 on Linux

Additional information

I get the following traceback:

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 406, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 237, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-i686/egg/webadmin/web_ui.py", line 119, in process_request
    path_info)
  File "build/bdist.linux-i686/egg/acct_mgr/admin.py", line 48, in process_admin_request
    return self._do_users(req)
  File "build/bdist.linux-i686/egg/acct_mgr/admin.py", line 95, in _do_users
    _create_user(req, self.env, check_permissions=False)
  File "build/bdist.linux-i686/egg/acct_mgr/web_ui.py", line 53, in _create_user
    mgr.set_password(user, password)
  File "build/bdist.linux-i686/egg/acct_mgr/api.py", line 98, in set_password
    if self.password_store.set_password(user, password):
  File "build/bdist.linux-i686/egg/acct_mgr/htfile.py", line 55, in set_password
    self.userline(user, password))
  File "build/bdist.linux-i686/egg/acct_mgr/htfile.py", line 174, in userline
    return self.prefix(user) + htdigest(user, self.realm, password)
  File "build/bdist.linux-i686/egg/acct_mgr/pwhash.py", line 100, in htdigest
    p = ':'.join([user, realm, password])
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 0: ordinal not in range(128)

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by mgood

  • Resolution set to duplicate
  • Status changed from new to closed

Looks like a dup of #2327.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from mgood. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.