Modify

Opened 7 years ago

Closed 6 years ago

#2914 closed defect (fixed)

No screenshots renderer enabled. Enable at least one.

Reported by: anonymous Owned by: Blackhex
Priority: normal Component: ScreenshotsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

I've installed the TracScreenshots plugin, but am getting an error:

"No screenshots renderer enabled. Enable at least one."

Here's what I did...

  • Installed python-imaging-1.1.5-5.el5 (PIL) and tested basic installation using python command line.
  • (Also installed ImageMagik since this was mentioned in a ticket somewhere)
  • Installed TracScreenshots plugin
  • Modified trac.ini
    [components]
    tracscreenshots.api.screenshotsapi = enabled
    tracscreenshots.core.screenshotscore = enabled
    tracscreenshots.init.screenshotsinit = enabled
    #tracscreenshots.matrix_view.screenshotsmatrixview = enabled
    tracscreenshots.tags.screenshotstags = enabled
    tracscreenshots.wiki.screenshotswiki = enabled
    
    
    [screenshots]
    default_components = component1
    default_format = html
    default_versions = 1.0
    ext = jpg,png
    formats = raw,html,jpg,png
    mainnav_title = Screenshots
    metanav_title =
    path = /data/trac/gateway/screenshots
    
  • ran trac-admin $(pwd) upgrade
  • restarted web server
  • As admin user clicked on the SCREENSHOTS tab

I get an error:

'No screenshots renderer enabled. Enable at least one.'

In the trac log in DEBUG mode I also get

[root@ncoh141-svn001 gateway]# 2008-04-15 10:59:49,366 Trac[loader] DEBUG: Loading egg plugin webadmin.logging from /usr/lib/python2.4/site-packages/TracWebAdmin-0.1.2dev_r5911-py2.4.egg
2008-04-15 10:59:49,368 Trac[loader] DEBUG: Loading egg plugin webadmin.ticket from /usr/lib/python2.4/site-packages/TracWebAdmin-0.1.2dev_r5911-py2.4.egg
2008-04-15 10:59:49,376 Trac[loader] DEBUG: Loading egg plugin webadmin.basics from /usr/lib/python2.4/site-packages/TracWebAdmin-0.1.2dev_r5911-py2.4.egg
2008-04-15 10:59:49,377 Trac[loader] DEBUG: Loading egg plugin webadmin.perm from /usr/lib/python2.4/site-packages/TracWebAdmin-0.1.2dev_r5911-py2.4.egg
2008-04-15 10:59:49,378 Trac[loader] DEBUG: Loading egg plugin webadmin.web_ui from /usr/lib/python2.4/site-packages/TracWebAdmin-0.1.2dev_r5911-py2.4.egg
2008-04-15 10:59:49,379 Trac[loader] DEBUG: Loading egg plugin webadmin.plugin from /usr/lib/python2.4/site-packages/TracWebAdmin-0.1.2dev_r5911-py2.4.egg
2008-04-15 10:59:49,419 Trac[loader] DEBUG: Loading egg plugin macropost.web_ui from /usr/lib/python2.4/site-packages/TracMacroPost-0.1-py2.4.egg
2008-04-15 10:59:49,422 Trac[loader] DEBUG: Loading egg plugin addcomment.macro from /usr/lib/python2.4/site-packages/TracAddCommentMacro-0.2-py2.4.egg
2008-04-15 10:59:49,439 Trac[loader] DEBUG: Loading egg plugin TracScreenshots.core from /usr/lib/python2.4/site-packages/TracScreenshots-0.5-py2.4.egg
2008-04-15 10:59:49,452 Trac[loader] DEBUG: Loading egg plugin TracScreenshots.tags from /usr/lib/python2.4/site-packages/TracScreenshots-0.5-py2.4.egg
2008-04-15 10:59:49,474 Trac[loader] DEBUG: Loading egg plugin TracScreenshots.init from /usr/lib/python2.4/site-packages/TracScreenshots-0.5-py2.4.egg
2008-04-15 10:59:49,477 Trac[loader] DEBUG: Loading egg plugin TracScreenshots.matrix_view from /usr/lib/python2.4/site-packages/TracScreenshots-0.5-py2.4.egg
2008-04-15 10:59:49,478 Trac[loader] DEBUG: Loading egg plugin TracScreenshots.api from /usr/lib/python2.4/site-packages/TracScreenshots-0.5-py2.4.egg
2008-04-15 10:59:49,479 Trac[loader] DEBUG: Loading egg plugin TracScreenshots.wiki from /usr/lib/python2.4/site-packages/TracScreenshots-0.5-py2.4.egg
2008-04-15 10:59:49,490 Trac[loader] DEBUG: Loading egg plugin acct_mgr.admin from /usr/lib/python2.4/site-packages/TracAccountManager-0.1.3dev_r2548-py2.4.egg
2008-04-15 10:59:49,542 Trac[loader] DEBUG: Loading egg plugin acct_mgr.db from /usr/lib/python2.4/site-packages/TracAccountManager-0.1.3dev_r2548-py2.4.egg
2008-04-15 10:59:49,545 Trac[loader] DEBUG: Loading egg plugin acct_mgr.htfile from /usr/lib/python2.4/site-packages/TracAccountManager-0.1.3dev_r2548-py2.4.egg
2008-04-15 10:59:49,548 Trac[loader] DEBUG: Loading egg plugin acct_mgr.http from /usr/lib/python2.4/site-packages/TracAccountManager-0.1.3dev_r2548-py2.4.egg
2008-04-15 10:59:49,549 Trac[loader] DEBUG: Loading egg plugin acct_mgr.pwhash from /usr/lib/python2.4/site-packages/TracAccountManager-0.1.3dev_r2548-py2.4.egg
2008-04-15 10:59:49,550 Trac[loader] DEBUG: Loading egg plugin acct_mgr.web_ui from /usr/lib/python2.4/site-packages/TracAccountManager-0.1.3dev_r2548-py2.4.egg
2008-04-15 10:59:49,551 Trac[loader] DEBUG: Loading egg plugin acct_mgr.api from /usr/lib/python2.4/site-packages/TracAccountManager-0.1.3dev_r2548-py2.4.egg
2008-04-15 10:59:49,553 Trac[loader] DEBUG: Loading egg plugin tractags from /usr/lib/python2.4/site-packages/TracTags-0.4.1-py2.4.egg
2008-04-15 10:59:49,628 Trac[init] DEBUG: SELECT value FROM system WHERE name='screenshots_version'
2008-04-15 10:59:49,686 Trac[core] DEBUG: action: None
2008-04-15 10:59:49,687 Trac[core] DEBUG: actions: ['view']
2008-04-15 10:59:49,688 Trac[main] WARNING: 500 Internal Error (No screenshots renderer enabled. Enable at least one.)

I've tried adding and removing the #tracscreenshots.matrix_view.screenshotsmatrixview = enabled line with no difference to the result.

Attachments (1)

screenshots-matrix-view.html (3.9 KB) - added by Blackhex 6 years ago.
Updated template.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 7 years ago by Blackhex

  • Status changed from new to assigned

If you are possitive that you've tried uncommented line:

tracscreenshots.matrix_view.screenshotsmatrixview = enabled

and restarted server with it, the I'd like to know your server evnironment (Apache+CGI+SQLite, Apache+mod_python+PostgreSQL, etc.)

Am I right that listed debug log is from time where you had that option enabled?

BTW: ImageMagick is no longer used.

comment:2 Changed 7 years ago by anonymous

Hi, Thanks for getting back to me

Environment is

  • Centos5
  • httpd-2.2.3-6.el5.centos.1
  • mod_python-3.2.8-3.1
  • python-2.4.3-19.el5
  • Default database (sqlite I think)

Heres the components section of the trac with the matrix view enabled

[components]
acct_mgr.admin.accountmanageradminpage = enabled
acct_mgr.api.accountmanager = enabled
acct_mgr.htfile.abstractpasswordfilestore = enabled
acct_mgr.htfile.htpasswdstore = enabled
acct_mgr.pwhash.htpasswdhashmethod = enabled
acct_mgr.web_ui.accountmodule = enabled
acct_mgr.web_ui.loginmodule = enabled
acct_mgr.web_ui.registrationmodule = enabled
addcomment.macro.addcommentmacro = enabled
macropost.web_ui.macropostmodule = enabled
trac.wiki.web_ui.wikimodule = disabled
tracscreenshots.api.screenshotsapi = enabled
tracscreenshots.core.screenshotscore = enabled
tracscreenshots.init.screenshotsinit = enabled
tracscreenshots.matrix_view.screenshotsmatrixview = enabled
tracscreenshots.tags.screenshotstags = enabled
#TracScreenshots.timeline.ScreenshotsTimeline = enabled
tracscreenshots.wiki.screenshotswiki = enabled
tractags.* = enabled
webadmin.* = enabled

And restarted the httpd server. It now works which is really odd since I'm certain I'd been through exactly the same steps at some point yesterday!!

(And I'm also pretty sure there was no # in front of the line mentioned when I tried it previously since the first time I enabled the matrixview I ticked a box in Webadmin and this added the line automatically)

I'm puzzled as to why this may be - you're probably thinking 'PEBCAK' and I'm begining to suspect so myself!

Thanks very much for your help. I'll now go ahead and install the plugin onto our production trac server.

Mark

PS As a bonus you now have this error case documented should someone else come looking ;)

comment:3 Changed 7 years ago by Blackhex

  • Resolution set to worksforme
  • Status changed from assigned to closed

Hmm. The fact is that the error message is thrown when and "only" when ScreenshotsMatrixView component is not enabled or loaded. I can't decide what went wrong since I don't know what have you exactly done but the weird thing is that in the log component seems loaded. I'll close this ticket for now, but if it will happen aggain I'll take it more seriously.

comment:4 Changed 7 years ago by anonymous

i had to do the same thing, works for me too

comment:5 Changed 7 years ago by anonymous

  • Priority changed from normal to high
  • Resolution worksforme deleted
  • Status changed from closed to reopened

I have exactly the same problem.

comment:6 Changed 7 years ago by Blackhex

Could you post your debug log?

comment:7 Changed 7 years ago by anonymous

2008-06-06 20:31:03,310 Trac[core] DEBUG: action: None
2008-06-06 20:31:03,311 Trac[core] DEBUG: actions: ['view']
2008-06-06 20:31:03,312 Trac[main] WARNING: 500 Internal Error (No screenshots renderer enabled. Enable at least one.)
2008-06-06 20:31:03,821 Trac[loader] DEBUG: Loading egg plugin timingandestimationplugin from /usr/share/trac/plugins/timingandestimationplugin-0.6.6-py2.4.egg
2008-06-06 20:31:03,833 Trac[loader] DEBUG: Loading egg plugin webadmin.logging from /usr/lib/python2.4/site-packages
2008-06-06 20:31:03,838 Trac[loader] DEBUG: Loading egg plugin webadmin.ticket from /usr/lib/python2.4/site-packages
2008-06-06 20:31:03,847 Trac[loader] DEBUG: Loading egg plugin webadmin.basics from /usr/lib/python2.4/site-packages
2008-06-06 20:31:03,848 Trac[loader] DEBUG: Loading egg plugin webadmin.perm from /usr/lib/python2.4/site-packages
2008-06-06 20:31:03,850 Trac[loader] DEBUG: Loading egg plugin webadmin.web_ui from /usr/lib/python2.4/site-packages
2008-06-06 20:31:03,851 Trac[loader] DEBUG: Loading egg plugin webadmin.plugin from /usr/lib/python2.4/site-packages
2008-06-06 20:31:03,866 Trac[loader] DEBUG: Loading egg plugin TracScreenshots.core from /usr/share/trac/plugins/TracScreenshots-0.5-py2.4.egg
2008-06-06 20:31:03,905 Trac[loader] DEBUG: Loading egg plugin TracScreenshots.tags from /usr/share/trac/plugins/TracScreenshots-0.5-py2.4.egg
2008-06-06 20:31:03,913 Trac[loader] WARNING: Cannot load plugin TracScreenshots.tags because it requires "TracTags"
2008-06-06 20:31:03,914 Trac[loader] DEBUG: Loading egg plugin TracScreenshots.init from /usr/share/trac/plugins/TracScreenshots-0.5-py2.4.egg
2008-06-06 20:31:03,915 Trac[loader] DEBUG: Loading egg plugin TracScreenshots.matrix_view from /usr/share/trac/plugins/TracScreenshots-0.5-py2.4.egg
2008-06-06 20:31:03,916 Trac[loader] DEBUG: Loading egg plugin TracScreenshots.api from /usr/share/trac/plugins/TracScreenshots-0.5-py2.4.egg
2008-06-06 20:31:03,917 Trac[loader] DEBUG: Loading egg plugin TracScreenshots.wiki from /usr/share/trac/plugins/TracScreenshots-0.5-py2.4.egg
2008-06-06 20:31:03,941 Trac[loader] DEBUG: Loading plugin /usr/share/trac/plugins/TracGantt-0.3.2a-py2.4.egg
2008-06-06 20:31:03,949 Trac[loader] DEBUG: Loading egg plugin acct_mgr.admin from /usr/lib/python2.4/site-packages/TracAccountManager-0.1.3dev_r3729-py2.4.egg
2008-06-06 20:31:03,963 Trac[loader] DEBUG: Loading egg plugin acct_mgr.db from /usr/lib/python2.4/site-packages/TracAccountManager-0.1.3dev_r3729-py2.4.egg
2008-06-06 20:31:03,965 Trac[loader] DEBUG: Loading egg plugin acct_mgr.htfile from /usr/lib/python2.4/site-packages/TracAccountManager-0.1.3dev_r3729-py2.4.egg
2008-06-06 20:31:03,968 Trac[loader] DEBUG: Loading egg plugin acct_mgr.http from /usr/lib/python2.4/site-packages/TracAccountManager-0.1.3dev_r3729-py2.4.egg
2008-06-06 20:31:03,969 Trac[loader] DEBUG: Loading egg plugin acct_mgr.pwhash from /usr/lib/python2.4/site-packages/TracAccountManager-0.1.3dev_r3729-py2.4.egg
2008-06-06 20:31:03,970 Trac[loader] DEBUG: Loading egg plugin acct_mgr.web_ui from /usr/lib/python2.4/site-packages/TracAccountManager-0.1.3dev_r3729-py2.4.egg
2008-06-06 20:31:03,971 Trac[loader] DEBUG: Loading egg plugin acct_mgr.api from /usr/lib/python2.4/site-packages/TracAccountManager-0.1.3dev_r3729-py2.4.egg
2008-06-06 20:31:04,058 Trac[init] DEBUG: SELECT value FROM system WHERE name='screenshots_version'

comment:8 Changed 7 years ago by anonymous

By the way, warning about Tags appears while I have tag options disabled.

comment:9 Changed 7 years ago by Blackhex

This leads me to question if this is not related to local/global trac.ini misconfiguration. I mean: Are you sure that ScreenshotsTags component is disabled and ScreenshotsMatrixView is enabled in trac.ini that has precedence and you didn't checking this in trac.ini that has not?

comment:10 Changed 6 years ago by Blackhex

  • Resolution set to invalid
  • Status changed from reopened to closed

I suspect that it's invalid, reopen it if you experience this aggain and are you sure that your global component configuration is not colliding with local and try to give me some leads how to reproduce it.

comment:11 Changed 6 years ago by eppa@…

  • Priority changed from high to normal
  • Resolution invalid deleted
  • Status changed from closed to reopened

I experienced this problem when installing the plugin using the Installation procedure. It resolved when setting tracscreenshots.matrix_view.screenshotsmatrixview = enabled in trac.ini like described in this ticket. However it is not mentioned in the installation procedure that you have to put in that line.

It now works fine with one small "quirk", the Trac menu now shows up twice (second below the first one) when in the Screenshots Tab.

My configuration is a multiproject setup.

Component section that now works:

[components]
iniadmin.iniadmin.iniadminplugin = enabled
svnhooks.svnhooks.svnhooksplugin = enabled
webadmin.* = enabled
webadmin.basics.projectadminpage = enabled
webadmin.perm.permissionadminpage = enabled
TracScreenshots.init.ScreenshotsInit = enabled
TracScreenshots.core.ScreenshotsCore = enabled
TracScreenshots.api.ScreenshotsApi = enabled
TracScreenshots.matrix_view.screenshotsmatrixview = enabled
TracScreenshots.wiki.ScreenshotsWiki = enabled
TracScreenshots.timeline.ScreenshotsTimeline = enabled # For 0.11 branch.
TracScreenshots.tags.ScreenshotsTags = disabled

Regards Espen

comment:12 Changed 6 years ago by Blackhex

Thanks for response. I didn't noticed that the documentation is not complete in this matter. It's updated now.

Concerning your double menu issue: Are you sure it's not caused by any other plugin? Try to disable any you have additionally installed and reproduce. If it will be still there please give me some more info about your environment (web server type, exact trac version, web client type) and you can post me html code of rendered page too. Thank you.

comment:13 Changed 6 years ago by eppa@…

Ok,tried with all plugins except TracScreenshots disabled. And it was still the same.

you can see the effect on: http://tank.onomato.biz/screenshots Seems the new html,head and body tags get inserted right after page title (H1 tag) Problem is the same for Firefox, IE and Chrome

(i can send you the html in a mail if you want)

System Information (from Trac About)

System Information
Trac: 	0.11
Python: 	2.5.2 (r252:60911, Oct 5 2008, 19:42:18) [GCC 4.3.2]
setuptools: 	0.6c8
SQLite: 	3.5.9
pysqlite: 	2.4.1
Genshi: 	0.5
mod_python: 	3.3.1
Pygments: 	0.9
Subversion: 	1.5.1 (r32289)
jQuery:	1.2.3

Web Server:

Server version: Apache/2.2.9 (Ubuntu)
Server built:   Sep 19 2008 13:43:21

System: Ubuntu 8.10

Regards Espen

comment:14 Changed 6 years ago by Blackhex

It should be fixed if you replace your screenshots-matrix-view.html with attached one, but I think it's bug in older verison of Trac 0.11. Do you use Trac 0.11.0 or recent version 0.11.2?

Changed 6 years ago by Blackhex

Updated template.

comment:15 Changed 6 years ago by anonymous

I am using 0.11-2 (took awhile to figure that out) "aptitude show trac" output:

Package: trac
State: installed
Automatically installed: no
Version: 0.11-2

Tried to replace the HTML file within the sources, but i've not been able to actually replace it. (it still is the old one showing). Not sure im doing this right (replaced the html file in the templates folder of the plugin, then rebuild the egg, then install the egg. but it seems the egg doesnt update the html file inside (tried renaming egg to zip, and checked in templates folder, and html file was the old one)

comment:16 Changed 6 years ago by anonymous

Whenever i try to do easy_install with the new html file i get

zipimport.ZipImportError: bad local file header in /usr/lib/python2.5/site-packages/TracScreenshots-0.7-py2.5.egg

I then tried with the original source, and that allowed easy_install to run, i then manually edited the html file, and got that error message again :(

comment:17 Changed 6 years ago by eppa@…

Finally managed to replace the html file, and it worked perfectly (removing the double menu).

comment:18 Changed 6 years ago by Blackhex

  • Resolution set to fixed
  • Status changed from reopened to closed

OK, I'll not commit update to repository, because IMHO current state is correct and problem is in Trac (unless you have newer version than me).

Add Comment

Modify Ticket

Action
as closed The owner will remain Blackhex.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.