Modify

Opened 6 years ago

Closed 4 years ago

#2978 closed defect (worksforme)

TaskListPlugin error while enabling it

Reported by: gabriel.scolan@… Owned by: pacopablo
Priority: normal Component: TaskListPlugin
Severity: normal Keywords:
Cc: zeph.gillen@… Trac Release: 0.11

Description (last modified by pacopablo)

I've tried to install the TaskListPlugin (see http://trac-hacks.org/wiki/TaskListPlugin)
but I've got the following error message while enabling it:

Traceback (most recent call last):
  File "c:\python25\lib\site-packages\Trac-0.12dev_r6942-py2.5.egg\trac
\web\api.py", line 339, in send_error
    'text/html')
  File "c:\python25\lib\site-packages\Trac-0.12dev_r6942-py2.5.egg\trac
\web\chrome.py", line 683, in render_template
    template = self.load_template(filename, method=method)
  File "c:\python25\lib\site-packages\Trac-0.12dev_r6942-py2.5.egg\trac
\web\chrome.py", line 659, in load_template
    self.templates = TemplateLoader(self.get_all_templates_dirs(),
  File "c:\python25\lib\site-packages\Trac-0.12dev_r6942-py2.5.egg\trac
\web\chrome.py", line 406, in get_all_templates_dirs
    dirs += provider.get_templates_dirs()
  File "build\bdist.win32\egg\tasklist\main.py", line 200, in
get_templates_dirs
    from pkg_resources import resource_filename
SystemError: Parent module 'tasklist' not loaded

I'm using:

  • Trac -r6942
  • Genshi 0.5 from trunk -r847
  • setup tools setuptools-0.6c7-py2.5

I've configured the ini file as follow:

[tasklist]
tasklist_field = action_item
default_cols = summary,priority
default_query = 'status!=closed&owner=$USER'
default_anonymous_query = 'status!=closed&cc~=$USER'

[components]
tasklist.* = enabled

[ticket-custom]
action_item = text
action_item.label = Action Item 

Attachments (0)

Change History (8)

comment:1 Changed 6 years ago by anonymous

  • Trac Release changed from 0.10 to 0.11

comment:2 Changed 6 years ago by pacopablo

  • Description modified (diff)
  • Status changed from new to assigned

Cleaned up description formatting

comment:3 Changed 6 years ago by anonymous

  • Cc zeph.gillen@… added

comment:4 Changed 6 years ago by pacopablo

Please try r3627 of trunk. I can replicate the issue you're having, but this may fix it.

comment:5 Changed 6 years ago by pacopablo

I should have said that I can't replicate the error. Anyway, a possibly related ticket is #3018

comment:6 Changed 6 years ago by kate@…

I have a little more info and a solution that worked for me.
After enabling the plugin, I got the same error.

Creating [tasklist] and [ticket-custom] sections in trac.ini file fixed the problem.

comment:7 in reply to: ↑ description Changed 4 years ago by rjollos

Replying to gabriel.scolan@gmx.net:

I've configured the ini file as follow:

You should not put single quotes around default_query and default_anonymous_query when defining them in the [tasklist] section of trac.ini. For that matter though, you don't need to define the [tasklist] section since the defaults will be used.

That said, I get a different error than you when I add the single quotes, so you might have another issue as well.

comment:8 Changed 4 years ago by rjollos

  • Resolution set to worksforme
  • Status changed from assigned to closed

Please test again with Trac >= 0.12 and the latest version of the TaskListPlugin trunk, and reopen if you continue to have issues. See also #6336.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from pacopablo. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.