Modify

Opened 6 years ago

Closed 6 years ago

#3006 closed defect (wontfix)

upgrade fails

Reported by: anonymous Owned by: coling
Priority: normal Component: WorkLogPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description

trac-admin upgrade alwayr run to the end, but in the log

ERROR: WorklogPlugin Exception: error de sintaxis en o cerca de «user» at character 24

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by coling

I'm guessing you are using Postgres as a DB backend right? It's got problems with using "user" as a field name. I've fixed this but only in the 0.11 branch. I'm no longer working on the 0.10 branch as I don't have an environment to test on.

If you are interested you can probably take the changeset(s) from the 0.11 branch and back port it to 0.10. I'm hoping trac 0.11 will be out in a few weeks so everyone can upgrade :)

comment:2 Changed 6 years ago by coling

  • Resolution set to wontfix
  • Status changed from new to closed

I should say that if you do backport a patch and test it, please reopen this ticket and attach it. I will happily blindly apply patches to 0.10 if users report them as working :)

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.